Bug 1432990 - registration failure message due an empty/corrupt cert in /etc/rhsm/ca folder is not appropriate
Summary: registration failure message due an empty/corrupt cert in /etc/rhsm/ca folder...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-16 14:07 UTC by Shwetha Kallesh
Modified: 2017-08-01 19:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:21:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Shwetha Kallesh 2017-03-16 14:07:52 UTC
Description of problem:
registration failure message due an empty/corrupt cert in /etc/rhsm/ca folder is not appropriate

Version-Release number of selected component (if applicable):
[root@dhcp35-101 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.19.1-1.git.830.8f73a6c.el7
python-rhsm: 1.19.1-1.git.5745.8f73a6c.el7


How reproducible:


Steps to Reproduce:
Create an empty cert:
[root@dhcp35-101 ~]# touch /etc/rhsm/ca/myemptycert.pem

Now try to register:
[root@dhcp35-101 ~]# subscription-manager register --force
Registering to: Shwetha-Candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Unable to verify server's identity: unknown error (_ssl.c:2747)


Actual results:


Expected results:


Additional info:

Comment 2 Barnaby Court 2017-03-16 14:52:29 UTC
Shwetha, can you remind us what the old behavior was and how this has changed?

Comment 3 Shwetha Kallesh 2017-03-17 09:28:49 UTC
Barnaby,
            
       Previously displayed message was "Bad CA certificate: <file path>"

Comment 5 Shwetha Kallesh 2017-04-20 13:57:35 UTC
[root@cisco-b200m1-03 ~]# touch /etc/rhsm/ca/myemptycert.pem
[root@cisco-b200m1-03 ~]# subscription-manager register --force
Bad CA certificate: /etc/rhsm/ca/myemptycert.pem


[root@cisco-b200m1-03 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7

Comment 6 errata-xmlrpc 2017-08-01 19:21:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.