Bug 1433018 - cns-deploy fails to ensure that nodes are properly labeled during cns setup
Summary: cns-deploy fails to ensure that nodes are properly labeled during cns setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: CNS 3.5
Assignee: Ramakrishna Reddy Yekulla
QA Contact: Tejas Chaphekar
URL:
Whiteboard: aos-scalability-35
Depends On:
Blocks: 1415600
TreeView+ depends on / blocked
 
Reported: 2017-03-16 15:07 UTC by Elvir Kuric
Modified: 2017-04-20 18:27 UTC (History)
11 users (show)

Fixed In Version: cns-deploy-4.0.0-11.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:27:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Elvir Kuric 2017-03-16 15:07:30 UTC
Description of problem:

cns-deploy does not ensure that nodes are properly labeled during cns setup

If for some reason OCP infrastructure has some temporary issue when cns-deploy is ran then for some nodes cns-deploy will report error message 

--- 
/usr/bin/oc -n cnselko label nodes dhcp4-25.ocp.net storagenode=glusterfs
Error from server (ServerTimeout): the server cannot complete the requested operation at this time, try again later (get nodes dhcp4-25.ocp.net)
+ read -r node

--- 

Version-Release number of selected component (if applicable):
cns-deploy-3.1.0-14.el7rhgs.x86_64

How reproducible:
I got this issue 2x 

Steps to Reproduce:

I do not have clear reproducer, but I think OCP temporary problems when trying to label nodes can lead to this issue. 

Actual results:
if cns-deploy fails to label node it will proceed to next one without ensuring that nodes are actually properly labeled


Expected results:
cns-deploy to exit/fail if node labeling fails for any reason 

Additional info:
na

Comment 2 Humble Chirammal 2017-03-17 07:43:16 UTC
I am not sure in which scenario #oc fails to label the node. Any way, its good to have a check before proceeding.

Comment 6 Ramakrishna Reddy Yekulla 2017-03-28 10:58:57 UTC
cns-deploy aborts if node labeling fails,

Comment 7 Mohamed Ashiq 2017-03-28 13:13:10 UTC
(In reply to Ramakrishna Reddy Yekulla from comment #6)
> cns-deploy aborts if node labeling fails,

This is not there in cns-deploy see comment#2.

Comment 9 Ramakrishna Reddy Yekulla 2017-03-30 11:21:45 UTC
The patch for the above is mentioned here upstream ::
https://github.com/gluster/gluster-kubernetes/pull/220

Comment 10 Michael Adam 2017-03-30 16:33:12 UTC
superseded (cosmetically) by
https://github.com/gluster/gluster-kubernetes/pull/223
which has been merged upstream.
will get into next build.

Comment 12 errata-xmlrpc 2017-04-20 18:27:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112


Note You need to log in before you can comment on or make changes to this bug.