Bug 143304 - Impossible to enter interactive boot sequence ?
Impossible to enter interactive boot sequence ?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-12-18 09:57 EST by Kim Lux
Modified: 2014-03-16 22:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 18:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rc.sysinit allow "I" for interactive (554 bytes, patch)
2005-01-29 12:20 EST, Jason Lempka
no flags Details | Diff

  None (edit)
Description Kim Lux 2004-12-18 09:57:39 EST
Description of problem: 
 
"Press I for interactive startup" doesn't work.  
 
 
Version-Release number of selected component (if applicable): 
 
FC3 with all updates as of December 16, 2004 
 
 
How reproducible: 
 
Every time.  
 
 
Steps to Reproduce: 
1. Boot FC3 
 
2. When the "Press I for interactive startup" is seen, press "I" or 
"i" 
   
Actual results: nothing happens 
 
Expected results: should go into interactive startup mode 
 
 
Additional info: 
 
in FC3 it seems that was disabled. 
 
rc.sysinit: 
----------------------------- 
if [ "$PROMPT" != "no" ]; then 
 echo -en $"\t\tPress 'I' to enter interactive startup." 
 echo 
fi 
------------------------------ 
 
Same file on FC2: 
------------------------------- 
if [ "$PROMPT" != "no" ]; then 
 echo -en $"\t\tPress 'I' to enter interactive startup." 
 echo 
 sleep 1 
fi 
------------------------------- 
 
While this is a small difference it can mean the difference between 
possible (1 second delay) and impossible (no delay) 
 
Is this a joke that is being played on users or is there some reason 
for this ?
Comment 1 Bill Nottingham 2004-12-22 18:06:47 EST
If you add the 'sleep 1', does that actually work?
Comment 2 Jason Lempka 2005-01-29 12:20:40 EST
Created attachment 110390 [details]
rc.sysinit allow "I" for interactive
Comment 3 Jason Lempka 2005-01-29 12:23:48 EST
Adding 'sleep 1' makes no difference, but commenting out the following
in rc.sysinit made it work:

if strstr "$cmdline" confirm ; then
       touch /var/run/confirm
fi

(around line 921)

I've also left the 'sleep 1' in to allow a little more time for
hitting the "I".
Comment 4 Bill Nottingham 2005-01-31 15:19:48 EST
That really shouldn't make any difference. Will have to do some more
testing here.
Comment 5 John Reiser 2005-04-28 17:09:30 EDT
Same problem on FC4t2, Mac mini (ARCH=ppc), USB keyboard.  I typed 'I' or 'i'
immediately upon seeing the red letters in "Welcome to Fedora Core".  By then
the console had advanced to "Starting udev", but the green "[OK]" had not yet
appeared.

Workaround is to add " confirm" to end of boot line.
Comment 6 Dale E. Moore 2005-04-28 22:16:21 EDT
/etc/grub.conf was:
 kernel /vmlinuz-2.6.11-1.14_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
which fails Interactive boot; but Interactive boot works with:
 kernel /vmlinuz-2.6.11-1.14_FC3 ro root=/dev/VolGroup00/LogVol00

Comment 7 Bill Nottingham 2005-05-16 18:07:49 EDT
I can't reproduce this here; it works for me generally in testing; it *seems*
that it needs to be done after loading the default keymap, but ICBW.
Comment 8 Kim Lux 2006-03-24 02:30:46 EST
This is a problem again for me.  For a couple kernel versions it worked <great>.
 Pressing I would allow an interactive boot.   

I am now running 2.6.15-1.1833_FC4smp and again I can't boot in interactive mode
and I need to due to some issues I am having with nfs.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.