Bug 1433047 - Packstack fails to deploy in OSP11 puddle 2017-03-15.2
Summary: Packstack fails to deploy in OSP11 puddle 2017-03-15.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-nova
Version: 11.0 (Ocata)
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: beta
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-16 16:11 UTC by Alfredo Moralejo
Modified: 2017-05-17 20:08 UTC (History)
5 users (show)

Fixed In Version: puppet-nova-10.4.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:08:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 441112 None None None 2017-03-17 12:08:02 UTC

Description Alfredo Moralejo 2017-03-16 16:11:20 UTC
Description of problem:

packstack --allinone fails to run. 

Following error appears in /var/tmp/packstack/latest/manifests/<ip>-controller.pp.log

Error: /Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Systemd start for httpd failed!

Mar 16 11:42:00 rhel.example.com httpd[14817]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8778
Mar 16 11:42:00 rhel.example.com httpd[14817]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8778


Version-Release number of selected component (if applicable):

puppet-nova-10.3.0-0.20170220173041.97656fb.el7ost.noarch
openstack-packstack-10.0.0-0.20170306153813.403a7dd.el7ost.noarch

How reproducible:

Always

Steps to Reproduce:
1. yum install packstack
2. packstack --allinone

Actual results:

Packstack exits with error message:

ERROR : Error appeared during Puppet run: 192.168.121.186_controller.pp

Expected results:

packstack should finished successfully

Additional info:

The problem has been fixed in puppet-nova:

https://github.com/openstack/puppet-nova/commit/86a2d2d42230f8ef18ee818330d86b5e0a89a714

Comment 2 errata-xmlrpc 2017-05-17 20:08:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.