Bug 143313 - No more scsi scanner in FC3
No more scsi scanner in FC3
Status: CLOSED DUPLICATE of bug 161254
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-18 13:10 EST by Nicola
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-13 14:42:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola 2004-12-18 13:10:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
In FC2 all was fine. In FC3, no more scsi epson scanner.
cdrecord --scanbus gives:
       0,0,0     0) *
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) 'ADAPTEC ' 'ACB-5500        ' 'FAKE' NON CCS Disk
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

The scanner disappeared from the system.
It used to be present before.
I had to manually add the necessary sg device:
/etc/udev/rules.d]$ cat 20-scanner.rules 
# permissions for SCSI cd/sg devices and scanner
BUS="scsi", KERNEL="sg[0-9]*", SYSFS_type="5", NAME="%k",
GROUP="cdrom", MODE="0660"


Version-Release number of selected component (if applicable):
udev-039-10.FC3.6

How reproducible:
Always

Steps to Reproduce:
1. Install fc3
2. Start gimp, then acquire-> xsane
3. No device detected
    

Actual Results:  No devices found

Expected Results:  The scanner should be detected

Additional info:

Used to work in fc2. I fixed it by entering sg devices by hand
in /et/udev/rules:

/etc/udev/rules.d]$ cat 20-scanner.rules 
# permissions for SCSI cd/sg devices and scanner
BUS="scsi", KERNEL="sg[0-9]*", SYSFS_type="5", NAME="%k",
GROUP="cdrom", MODE="0660"
Comment 1 Nicola 2004-12-18 13:12:26 EST
Could it be possible to return to good old /dev structure without
messing fc3 installation?
Comment 2 Harald Hoyer 2005-01-20 11:14:25 EST
you may have to load the sg module, though that should have been done
with start_udev... do you have all updates for FC3? udev and
initscrips especially
Comment 3 G. Roderick Singleton 2005-02-19 12:55:03 EST
I have all updates, sg is loaded according to modinfo and yet my
scanner, a Relisys Scorpio is not recognized by sane, kooka. the
device is attached via an Adaptec 2940. I will try the workaround from
fc2 above.
Comment 4 Armijn Hemel 2005-03-09 04:54:42 EST
This problem bits me too. sane-find-scanner finds my scanner alright:

found SCSI scanner "Aashima IMAGERY 4800SP + 5.08" at /dev/sg0

In /proc/scsi/scsi my device is listed, all updates are installed on this
machine, the sg module is loaded, but yet I can't scan.

I didn't see any udev rules for SCSI scanners in /etc/udev/rules.d, maybe
there is the problem...
Comment 5 Armijn Hemel 2005-03-09 09:32:16 EST
The solution mentioned above does not fix the problem for me.
Comment 6 D. Hugh Redelmeier 2005-08-14 11:08:22 EDT
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161254
Comment 7 Armijn Hemel 2006-01-02 12:27:43 EST
I hadn't had any time to check this for a long while, but I added the rules
which were suggested in the other bugreport and hey, everything worked as
expected. I really hope these rules will be default in later versions, as I'm
planning to update the machine the scanner is connected to to Fedora Core 5
later this year.
Comment 8 John Thacker 2007-01-13 14:42:27 EST

*** This bug has been marked as a duplicate of 161254 ***

Note You need to log in before you can comment on or make changes to this bug.