Bug 1433211 - Add a option to disable repos while generating gdeploy config file
Summary: Add a option to disable repos while generating gdeploy config file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.10.7-0.0.15
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.1.3
: 0.10.7-0.0.18
Assignee: Devyani Kota
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2 1447919 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-03-17 04:49 UTC by SATHEESARAN
Modified: 2017-08-28 10:33 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.19.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-06 14:05:08 UTC
oVirt Team: Gluster
sasundar: ovirt-4.1?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 74377 master MERGED gdeploy: Add option disable repos while generating gdeploy config file 2017-04-19 12:36:15 UTC
oVirt gerrit 75632 ovirt-4.1 MERGED gdeploy: Add option disable repos while generating gdeploy config file 2017-04-20 12:18:06 UTC
oVirt gerrit 77079 master MERGED gdeploy: Edit option 'disable-repos' while generating gdeploy config file. 2017-06-05 12:37:55 UTC
oVirt gerrit 77792 ovirt-4.1 MERGED gdeploy: Edit option 'disable-repos' while generating gdeploy config file. 2017-06-05 13:20:54 UTC

Description SATHEESARAN 2017-03-17 04:49:28 UTC
Description of problem:
------------------------
[RH-subscription] section of gdeploy by default has 'disable-repos=no' which enables all the repos ( atleast with Employee SKU ). It is necessary to have 'disable-repo=yes' under [RH-subscription] section of generated gdeploy config file

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.7-0.0.15

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Start gluster deployment with cockpit 
2. Provide CDN credentials, repos, packages

Actual results:
---------------
All the available repos are enabled

Expected results:
------------------
Only the required repos should be enabled


Additional info:

Comment 1 SATHEESARAN 2017-05-22 07:02:18 UTC
Tested with cockpit-ovirt-dashboard-0.10.7-0.0.18.el7ev

The option to disable repos is incorrect. It should be 'disable-repos=yes' and not 'disable_repos=yes'

snip from /usr/lib/python2.7/site-packages/gdeployfeatures/rh_subscription/rh_subscription.json 

<snip>
           {
              "required": "false",
              "name": "disable-repos",
              "default": "no"
            },

</snip>

Comment 2 Red Hat Bugzilla Rules Engine 2017-05-22 07:02:23 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Sandro Bonazzola 2017-05-26 07:30:09 UTC
Patch 77079 is not yet merged, can you please check if it's needed for this bug?
If not, please remove it from external trackers.
If yes, this bug should be in POST state.

Comment 5 Devyani Kota 2017-05-26 11:07:58 UTC
Sandro, hi
Apologies, wasn't aware of the purpose of the "MODIFIED" tag.

Thanks,
Devyani Kota.

Comment 6 SATHEESARAN 2017-07-02 18:40:17 UTC
Tested with cockpit-ovirt-dashboard-0.10.7-0.0.20

The generated gdeploy config file has 'disable-repos' under the section 'RH-subscription', which disables all the repos available for that subscription


Note You need to log in before you can comment on or make changes to this bug.