Bug 1433239
| Summary: | same warning messages are printed multiple times | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | Xiaodai Wang <xiaodwan> | ||||
| Component: | virt-manager | Assignee: | Pavel Hrdina <phrdina> | ||||
| Status: | CLOSED ERRATA | QA Contact: | Virtualization Bugs <virt-bugs> | ||||
| Severity: | low | Docs Contact: | |||||
| Priority: | low | ||||||
| Version: | 7.4 | CC: | crobinso, juzhou, kuwei, mxie, mzhan, tzheng | ||||
| Target Milestone: | rc | ||||||
| Target Release: | --- | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | virt-manager-1.4.1-3.el7 | Doc Type: | If docs needed, set a value | ||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-08-01 21:02:03 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
|
Description
Xiaodai Wang
2017-03-17 07:21:46 UTC
Created attachment 1263966 [details]
virt-manager log
Fixed upstream sorta;
commit 9c8ffe51dacee208af4d5d7cc3e439ae7197fc09
Author: Cole Robinson <crobinso>
Date: Fri Mar 17 12:00:03 2017 -0400
storage: Move alloc/cap validation to validate()
The first two warnings are avoided, but you'll still get one WARN and one ERROR. If you disable the --check, you get one WARN. I'm fine with that since fixing it further would be a pain
I can reproduce this issue with build: virt-manager-1.4.1-1.el7.noarch virt-install-1.4.1-1.el7.noarch virt-manager-common-1.4.1-1.el7.noarch Then try to verify this bug with new build: virt-manager-1.4.1-2.el7.noarch virt-install-1.4.1-2.el7.noarch virt-manager-common-1.4.1-2.el7.noarch Steps: 1. # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) ERROR The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) (Use --check disk_size=off or --check all=off to override) Result: 1 warning and 1 error prompts. 2. Use --check disk_size=off # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ --check disk_size=off WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) Starting install... Retrieving file vmlinuz... | 4.1 MB 00:00:00 Retrieving file initrd.img... | 39 MB 00:00:03 ERROR Couldn't create storage volume 'vm1.img': 'numerical overflow: value too large: 10737418240000000000' Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start vm1 otherwise, please restart your installation. Result: 2 Warning and 1 error gets, it should only 1 warning i think, and error message it different from step1. 3. Use --check all=off # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ --check all=off WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 274820 M available) Starting install... Retrieving file vmlinuz... | 4.1 MB 00:00:00 Retrieving file initrd.img... | 39 MB 00:00:03 ERROR Couldn't create storage volume 'vm1.img': 'numerical overflow: value too large: 10737418240000000000' Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start vm1 otherwise, please restart your installation. Result: 2 Warning and 1 error gets, it should only 1 warning i think, and error message it different from step1. So Cole, please help have a look of step2 and step3, it different with Comment 3 said "If you disable the --check, you get one WARN." Thanks. It looks like the patch wasn't actually applied to the RHEL package, so this was incorrectly set to ON_QA (In reply to Pavel Hrdina from comment #8) > The patch was applied properly into the RHEL package, see: > Apologies, I was using an old checkout. Yeah that double warn on skip is an issue, I've fixed it upstream now: commit 7aee124d9aed7646e6e95644909c1d1005a92d07 Author: Cole Robinson <crobinso> Date: Thu Apr 27 12:19:53 2017 -0400 cli: Don't double warn when skipping disk size warning (bz 1433239) But it's so minor it's not worth backporting to RHEL IMO, so I suggest this is just marked VERIFIED or we just close UPSTREAM Try to verify this bug with new package: virt-manager-1.4.1-3.el7.noarch libvirt-3.2.0-4.el7.x86_64 qemu-kvm-rhev-2.9.0-2.el7.x86_64 Steps: Install a vm with disk size large than avaliable storage 1. # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 167668 M available) ERROR The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 167668 M available) (Use --check disk_size=off or --check all=off to override) 2. Use --check disk_size=off # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ --check disk_size=off WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 167668 M available) Starting install... Retrieving file vmlinuz... | 4.1 MB 00:00:00 Retrieving file initrd.img... | 39 MB 00:00:03 ERROR Couldn't create storage volume 'vm1.img': 'numerical overflow: value too large: 10737418240000000000' Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start vm1 otherwise, please restart your installation. 3. --check all=off # virt-install -n vm1 -r 1024 --disk path=/tmp/vm1.img,size=10000000000 -l http://download.eng.pek2.redhat.com/pub/rhel/released/RHEL-6/6.9/Server/x86_64/os/ --check all=off WARNING The requested volume capacity will exceed the available pool space when the volume is fully allocated. (10240000000000 M requested capacity > 167668 M available) Starting install... Retrieving file vmlinuz... | 4.1 MB 00:00:00 Retrieving file initrd.img... | 39 MB 00:00:03 ERROR Couldn't create storage volume 'vm1.img': 'numerical overflow: value too large: 10737418240000000000' Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start vm1 otherwise, please restart your installation. Result: The first two warnings in Step1 are avoided, you get one WARN and one ERROR. When we disable with --check in Step2 and Step3, we get one WARN, so move this bug from ON_QA to VERIFIED. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2017:2072 |