Bug 143327 - libsafe won't build on x86_64
Summary: libsafe won't build on x86_64
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsafe (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-19 08:12 UTC by Seth Vidal
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 21:11:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2004-12-19 08:12:30 UTC
Description of problem:
Build problem with libsafe on x86_64.

end of the errors received.
intercept.c:1550: warning: int format, different type arg (arg 3)
intercept.c: In function `realpath':
intercept.c:1584: warning: int format, different type arg (arg 3)
intercept.c:1599: warning: unsigned int format, different type arg (arg 2)
intercept.c:1599: warning: unsigned int format, different type arg (arg 3)
make[2]: *** [intercept.o] Error 1
make[2]: Leaving directory
`/rpmbuild/extras/cvs/rpms/libsafe/devel/libsafe-2.0-16/src'
make[1]: *** [libsafe] Error 2
make[1]: Leaving directory `/rpmbuild/extras/cvs/rpms/libsafe/devel/libsafe-2.0-16'
error: Bad exit status from /var/tmp/rpm-tmp.13915 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.13915 (%build)
make: *** [x86_64] Error 1

Comment 2 Seth Vidal 2004-12-20 03:15:38 UTC
Michael Schwendt suggested that libsafe could be/should be pulled from extras
entirely. At least he told me to exclude it from the build for now.


Comment 3 Warren Togami 2004-12-20 09:06:53 UTC
I'm interested to hear the reasons.  Does it screw package dependencies when
libsafe is installed in buildroot during rpmbuild?  If not then it should be
fine.  Software behavior should be the same.

Steve would you concur?


Comment 4 Steve Grubb 2004-12-20 14:35:55 UTC
I don't agree with pulling from the build. I'd like to hear the reason. 

It solves a different problem than some of the other security tools.
Some people are not able to use SE Linux because of strange local
configurations. Exec Shield may not solve all problems. There are
programs that need exec shield turned off. Also, for people still
running and maintaining RH 7.3, or other legacy distributions..there
is no hope of using exec shield.

That said, I don't know if it will actually *run* for x86_64. Its
stack layout has to be identical to IA32 family or I'll need to do
some investigation and re-work some code.

Comment 5 Warren Togami 2004-12-20 21:06:34 UTC
Steve, should we ExclusiveArch: i386 for now?


Comment 6 Steve Grubb 2004-12-20 21:26:01 UTC
Did the old version without my "c" patch work for x86_64? If not, I'd
say we should ExclusiveArch it for now. 

I'll fix the warnings so that maybe we can try it on an x86_64 to find
out. BTW, I don't have access to a x86_64 machine right now.

Comment 7 Michael Schwendt 2005-01-22 11:50:44 UTC
Re: comment 2

Only rationale for that suggestion was that libsafe had not been
updated or rebuilt since Red Hat Linux 8.0/9 and fedora.us' "patches"
repository,

  http://download.fedora.us/patches/redhat/9/i386/RPMS.stable/

and hence belonged to the potentially unmaintained packages which
should be checked before a rebuild is published. The FC3Status page

  http://fedoraproject.org/wiki/Extras_2fFC3Status

contained a comment about that.

Comment 8 Warren Togami 2005-01-23 06:14:31 UTC
Well "lack of maintainer" is no longer a problem.  And I agree that
libsafe is a useful optional add-on.  I say we ExclusiveArch: i386 for
now and keep this bug open.  Maybe it can be fixed for x86_64 later.

Comment 9 Steve Grubb 2005-01-23 13:12:25 UTC
I agree with ExclusiveArch. But adding x86_64 support is more of an RFE than a
bug report though.

Comment 10 Warren Togami 2005-01-29 21:11:45 UTC
ExclusiveArch: i386 is set.  Closing since x86_64 is not an intended
feature.


Comment 11 Warren Togami 2005-05-22 12:52:13 UTC
*** Bug 158451 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.