Bug 143328 - first kde system tray icon loaded does not go to gnome system tray
Summary: first kde system tray icon loaded does not go to gnome system tray
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-19 11:38 UTC by Mephisto
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 16:24:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mephisto 2004-12-19 11:38:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041216 Firefox/1.0 Fedora/1.0-6

Description of problem:
The first time i load a kde application that uses a system tray icon,
it does not go to the gnome system tray, but instead creates a small
window, just big enough to fit the icon, including a tasklist entry.
this has happened so far with k3b, skype and cedega (which seems also
written to use the kde tray, since it uses konqueror as default
browser). after loading just 1 such application, all subsequent
applications load fine, including the first application, if restarted.
havent tested with other kde applications with tray icon, cause i dont
have a lot, i prefer gnome apps.

Version-Release number of selected component (if applicable):
gnome-applets-2.8.0-5

How reproducible:
Always

Steps to Reproduce:
1. Reboot system
2. Log in to gnome
3. Start skype, k3b or cedega running Steam (gaming software -
www.steampowered.com)
    

Actual Results:  a small window has been created with the system tray
icon in it.

Expected Results:  the icon should have been placed in the gnome
system tray.

Additional info:

Comment 1 Mark McLoughlin 2004-12-20 14:11:11 UTC
Pretty sure this was reported before and we decided it was a KDE issue.

Comment 2 Ngo Than 2005-04-19 16:24:35 UTC
It's not reproduceable with new KDE-3.4.0 upstream. Uou find the kde-3.4.0
for FC3 on ftp.kde.org.


Note You need to log in before you can comment on or make changes to this bug.