Bug 143341 - icons in the gnome-window list
icons in the gnome-window list
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 12:29 EST by christoff_pale
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 09:13:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description christoff_pale 2004-12-19 12:29:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Some windows show icons in the window-list (gnome) while
others don't.
There should be a configuration option in the windowlist
so that users can assign icons to specific applications if they like.

Second, when one has a "alway group window" option enabled, the group
no longer shows icons sometimes.
For example, say I have 3 pdf's open in acroread. The acroread group
shows the pdf icon; however, when I have multiple xemacs
windows open, the xemacs group does not show xemacs icon (but simply a
plain white blank icon). Note however, that when only a since xemacs
window is open, the xemacs icon is shown correctly.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add window list to the gnome-panel
2.select "always group-windows"
3.open multiple xemacs, or xterm or acroread windows
    

Additional info:
Comment 1 Mark McLoughlin 2004-12-20 09:13:29 EST
The bug here is that these applications don't display an icon, you
need to log an individual bug against each of them.

The solution is to fix the bug in each of the applications rather than
a confusing "work around application bug" interface in the window list.
Comment 2 christoff_pale 2004-12-22 19:59:49 EST
True, it is the responsibility of the application to display the 
icons.
How about the icon for the group. Surely this is the gnome-panel's
responsibility.

Note You need to log in before you can comment on or make changes to this bug.