Bug 143342 - gamin segfaults
gamin segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 12:46 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 08:06:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gam_server gdb backtrace (1.79 KB, text/plain)
2004-12-19 12:46 EST, Ville Skyttä
no flags Details
Another gam_server gdb backtrace (2.32 KB, text/plain)
2005-02-19 19:01 EST, Ville Skyttä
no flags Details
gam_server debug trace (303.57 KB, text/plain)
2005-02-20 04:00 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2004-12-19 12:46:32 EST
Every now and then I find a core file produced by gam_server in my home dir. 
Haven't noticed what causes it.  Backtrace attached in case it's useful anyway.

This is gamin-0.0.19-1.FC3 from updates-testing, but I think I've seen it with
earlier versions too.
Comment 1 Ville Skyttä 2004-12-19 12:46:32 EST
Created attachment 108858 [details]
gam_server gdb backtrace
Comment 2 Daniel Veillard 2004-12-21 11:17:08 EST
Okay, thanks. In gam_tree_get_children if tree and root are NULL then the
code would segfault. Fixed in CVS, 

  thanks,

Daniel
Comment 3 Ville Skyttä 2004-12-22 12:51:47 EST
Nice, thanks.  Would it be possible to get a FC3 erratum for this?

By the way, I believe the app that I've seen most of these gamin segfaults
resulting from is kid3 from (pre-)Extras, using KDE on FC3.
Comment 4 Ville Skyttä 2005-02-19 19:01:39 EST
Created attachment 111233 [details]
Another gam_server gdb backtrace

I'm not sure if this is the same problem (the backtrace looks different), but
gamin-0.0.24-1.FC3 is even worse than the earlier versions.

Now, launching seemingly *any* KDE app remotely causes a gam_server crash. 
Like:

$ ssh somewhere
$ kiconedit
kbuildsycoca running...
[exit app, wait a while]
$ Mutex destroy failure: Device or resource busy
ICE default IO error handler doing an exit(), pid = 5750, errno = 0

** ERROR **: file gam_tree.c: line 146 (gam_tree_remove): assertion failed:
(g_node_n_children(node->node) == 0)
aborting...

Backtrace attached.
Comment 5 Daniel Veillard 2005-02-19 19:06:59 EST
Backtrace is not especially usful, get a debug trace from the gam_server
with kill -USR2 c.f. instructions at
http://www.gnome.org/~veillard/gamin/debug.html#Debugging1

Daniel
Comment 6 Ville Skyttä 2005-02-20 04:00:08 EST
Created attachment 111238 [details]
gam_server debug trace

Here you go.
Comment 7 Ville Skyttä 2005-03-04 14:22:31 EST
gamin-0.0.25-1.FC3 still has the problem.
Comment 8 Daniel Veillard 2005-03-15 08:06:25 EST
problem on #4 is a duplicate of #150471, which is fixed in rawhide
now.

Daniel
Comment 9 Ville Skyttä 2005-03-15 08:35:05 EST
Confirmed, 0.0.26-1 rebuilt on FC3 seems to be ok.  May I suggest a
FC3 errata for this?
Comment 10 Daniel Veillard 2005-03-15 08:40:59 EST
I will give it a few days in rawhide and then push an errata, yes.
It's being pushed to Mandrake Cooker and Ubuntu too so I think within
a week I will get any regression feedback.

Daniel
Comment 11 Denis Leroy 2005-04-15 11:53:48 EDT
Well it's been a month and it hasn't been pushed to FC3 yet. Could an 0.0.26
errata be pushed to FC3 please ? This thing lays core files on all my FC3
systems almos on a daily basis.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.