Bug 1433492 - Create Share Button in Manila Horizon UI Plugin is Not Visible
Summary: Create Share Button in Manila Horizon UI Plugin is Not Visible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Tom Barron
QA Contact: Dustin Schoenbrun
URL:
Whiteboard:
Depends On:
Blocks: 1326119 1393893
TreeView+ depends on / blocked
 
Reported: 2017-03-17 18:56 UTC by Dustin Schoenbrun
Modified: 2017-05-17 20:08 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:08:41 UTC


Attachments (Terms of Use)
Screenshot of the Horizon UI with No Create Share Button (175.69 KB, image/png)
2017-03-17 18:56 UTC, Dustin Schoenbrun
no flags Details
screen shot showing create shares button with upstream stable/ocata (42.71 KB, image/png)
2017-03-19 20:47 UTC, Tom Barron
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 448614 None None None 2017-03-22 15:20:53 UTC
Launchpad 1675075 None None None 2017-03-22 16:08:41 UTC

Description Dustin Schoenbrun 2017-03-17 18:56:32 UTC
Created attachment 1264255 [details]
Screenshot of the Horizon UI with No Create Share Button

Description of problem:
When you log into the Horizon UI with the Manila Horizon UI Plugin installed as either the admin user or a "regular" user, the Create Share button in the "Shares" tab in the "Shares" section of the Horizon UI is not present. 

Version-Release number of selected component (if applicable):
openstack-manila-ui-2.7.1-0.20170214092823.2e2ae51.el7ost.noarch

How reproducible:
Looks to be reproducible on Horizon instance regardless of Manila backend (tested with CephFS Native Driver and NetApp cDOT Driver)

Steps to Reproduce:
1. Install an OpenStack instance using OSP-Director, ensuring that Manila (and by extension the Manila Horizon UI Plugin) is installed.
2. Create a non-privileged user in the Overcloud for use in the Horizon UI.
3. Log in to the Horizon UI using the non-privileged user created in Step 2.
4. Navigate to the Shares section in the Horizon UI and click on the Shares tab.
5. Observe that the "Create Share" button is not visible (and is not hidden)

Actual results:
There is no button visible or available to create a Manila share through the Horizon UI in the Shares tab under the Shares section.

Expected results:
There should be a button in the Shares tab in the Shares section of the Horizon UI that will display the Create Share dialog.

Comment 2 Tom Barron 2017-03-19 20:47:05 UTC
Created attachment 1264653 [details]
screen shot showing create shares button with upstream stable/ocata

Comment 3 Tom Barron 2017-03-19 20:52:32 UTC
(In reply to Tom Barron from comment #2)
> Created attachment 1264653 [details]
> screen shot showing create shares button with upstream stable/ocata

Can't reproduce the issue upstream with stable/ocata, so I suspect there is something fishy with the downstream build or install.

One thing I notice is that downstream version is 2.7.1 with source  manila-ui-2.7.1.dev5-0.20170214092823.2e2ae51-2e2ae51e372http://tarballs.openstack.org/manila-ui/e7c916808072544e4ddb689a80950.tar.gz yet there is no 2.7.1 tag upstream and the last tarball at http://tarballs.openstack.org/manila-ui/ is 2.7.0.

Comment 4 Tom Barron 2017-03-19 20:55:17 UTC
(In reply to Tom Barron from comment #3)
> (In reply to Tom Barron from comment #2)
> > Created attachment 1264653 [details]
> > screen shot showing create shares button with upstream stable/ocata
> 
> Can't reproduce the issue upstream with stable/ocata, so I suspect there is
> something fishy with the downstream build or install.
> 
> One thing I notice is that downstream version is 2.7.1 with source 
> manila-ui-2.7.1.dev5-0.20170214092823.2e2ae51-2e2ae51e372http://tarballs.
> openstack.org/manila-ui/e7c916808072544e4ddb689a80950.tar.gz yet there is no
> 2.7.1 tag upstream and the last tarball at
> http://tarballs.openstack.org/manila-ui/ is 2.7.0.

Meant to say: One thing I notice is that downstream version is 2.7.1 with source 
> manila-ui-2.7.1.dev5-0.20170214092823.2e2ae51-2e2ae51e372.  But there is no
 2.7.1 tag upstream and the last tarball at http://tarballs.openstack.org/manila-ui/ is 2.7.0.

Comment 5 Red Hat Bugzilla Rules Engine 2017-03-20 09:18:44 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 6 Red Hat Bugzilla Rules Engine 2017-03-20 09:20:02 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 14 Tom Barron 2017-03-21 19:45:05 UTC
Dustin, would you test a potential workaround for this issue, as follows:

  1) on controller-0, edit /etc/openstack-dashboard/local_settings such that instead of OPENSTACK_API_VERSIONS={"identity":3} it has OPENSTACK_API_VERSIONS={"identity":2}.  This will configure horizon use keystone v2 instead of keystone v3.

  2) sudo systemctl restart httpd

  3) login to the dashboard fresh.  If you can't login, delete cookies and retry.

  4) check if $subject of this BZ is still an issue.

Comment 15 Dustin Schoenbrun 2017-03-21 20:26:52 UTC
Looks like this workaround fixes the issue that I was seeing. With the above workaround, I can see the Create Share button and clicking it brings up the Create Share page. I'm going to go ahead and keep working on the testing with this workaround.

Comment 16 Tom Barron 2017-03-22 15:21:56 UTC
We are testing a candidate fix that would backport versioneless endpoint for keystone to stable/ocata: https://review.openstack.org/#/c/448614

Comment 17 Tom Barron 2017-03-23 10:12:30 UTC
And in parallel we've posted a change to deploy horizon with configuration to use keystone v2: https://review.openstack.org/#/c/449027 .  We can go with this approach if backporting versionless endpoint to RHOS11 turns out to be too big of a change.

Comment 18 Tom Barron 2017-03-24 14:31:05 UTC
(In reply to Tom Barron from comment #16)
> We are testing a candidate fix that would backport versioneless endpoint for
> keystone to stable/ocata: https://review.openstack.org/#/c/448614

Deploying the overcloud with this patch fixes these issues.  I tested by deleting the overcloud stack in the RHOS11 cloud where this bug was discovered, applying this versionless keystone endpoint THT patch, and redeploying the overcloud.

Comment 19 Tom Barron 2017-03-27 12:03:06 UTC
Fix https://review.openstack.org/#/c/448614 has been merged upstream in stable/ocata.

Comment 21 Dustin Schoenbrun 2017-04-06 18:11:58 UTC
Using puddle version 2017-04-04.3 and openstack-tripleo-heat-templates-6.0.0-3.el7ost.noarch package for the TripleO Heat Templates, I was able to successfully log in to the Horizon UI, navigate to the Share section, and see the Create Share button. I was also able to click the button and follow the Create Share wizard to successfully create a share. 

I will note that the version of the openstack-tripleo-heat-templates package that I used to test this fix is not the same as the one listed in the Fixed in Version. I'm not sure if this is a typo or not, but at the very least the version I used seems to have fixed the issue we were seeing.

Comment 23 errata-xmlrpc 2017-05-17 20:08:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.