Bug 1433496 - tuned: fails to initialize plugin scheduler
Summary: tuned: fails to initialize plugin scheduler
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
(Show other bugs)
Version: 7.4
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Keywords: Patch, Regression, Upstream
Depends On:
Blocks: kvm-rt-tuned
TreeView+ depends on / blocked
 
Reported: 2017-03-17 19:13 UTC by Luiz Capitulino
Modified: 2017-08-01 12:35 UTC (History)
4 users (show)

Fixed In Version: tuned-2.8.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:35:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2102 normal SHIPPED_LIVE tuned bug fix and enhancement update 2017-08-01 16:07:33 UTC

Description Luiz Capitulino 2017-03-17 19:13:55 UTC
Description of problem:

While working on a KVM-RT issue I realized that the "[scheduler]" section of tuned.conf from the realtime-virtual-host profile is not being applied. Then I found this in the logs:

2017-03-17 14:08:57,259 ERROR    tuned.units.manager: failed to initialize plugin scheduler
2017-03-17 14:08:57,259 ERROR    tuned.units.manager: __init__() takes exactly 8 arguments (9 given)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tuned/units/manager.py", line 50, in create
    plugin = self._plugins_repository.create(plugin_name)
  File "/usr/lib/python2.7/site-packages/tuned/plugins/repository.py", line 36, in create
    self._device_matcher_udev, self._plugin_instance_factory, self._global_cfg, self._variables)
TypeError: __init__() takes exactly 8 arguments (9 given)



Version-Release number of selected component (if applicable): tuned-2.7.1-5.20170314git92d558b8.el7.noarch


How reproducible:


Steps to Reproduce:
1. Activate the realtime-virtual-host profile
2. Check /var/log/tuned/tuned.log

Comment 2 Jaroslav Škarvada 2017-03-17 19:25:29 UTC
Thanks for report we have already found it yesterday and are going to address it by next build.

Comment 3 Luiz Capitulino 2017-03-17 19:32:54 UTC
Do you have a patch I could apply locally so that this doesn't block me?

Comment 4 Jaroslav Škarvada 2017-03-17 19:40:31 UTC
(In reply to Luiz Capitulino from comment #3)
> Do you have a patch I could apply locally so that this doesn't block me?

Yes, upstream commit fixing the problem:
https://github.com/redhat-performance/tuned/commit/8ddd7acb40bcf1964f8dfbbdb5379306c0b21439

Your traceback really speeded things up, initally we triaged the bug to be fixed during next week :)

Comment 5 Luiz Capitulino 2017-03-17 19:42:08 UTC
Good, thanks a lot!

Comment 7 Jaroslav Škarvada 2017-03-21 09:39:25 UTC
It should be fixed in:
tuned*-2.7.1-1.20170321gita50d5e02.el7

available from:
https://jskarvad.fedorapeople.org/tuned/devel/repo/

Comment 8 Luiz Capitulino 2017-03-21 14:52:07 UTC
Works as expected, also passed short duration tests.

Comment 10 Tereza Cerna 2017-05-04 12:01:45 UTC
==============================================
Verified in:
    tuned-2.8.0-2.el7.noarch
    tuned-profiles-nfv-host-2.8.0-2.el7.noarch
PASS
==============================================

# cat /etc/tuned/realtime-virtual-host-variables.conf 
isolated_cores=2,4-7

# tuned-adm profile realtime-virtual-host

# cat /var/log/tuned/tuned.log
...
2017-05-04 07:59:30,524 INFO     tuned.profiles.loader: loading profile: realtime-virtual-host
2017-05-04 07:59:30,529 INFO     tuned.daemon.daemon: starting tuning
2017-05-04 07:59:30,533 INFO     tuned.plugins.base: instance cpu: assigning devices cpu14, cpu15, cpu16, cpu17, cpu10, cpu11, cpu12, cpu13, cpu18, cpu19, cpu30, cpu31, cpu8, cpu9, cpu6, cpu7, cpu4, cpu5, cpu2, cpu3, cpu0, cpu1, cpu29, cpu28, cpu25, cpu24, cpu27, cpu26, cpu21, cpu20, cpu23, cpu22
...

>>> No traceback

==============================================
Reproduced in:
    tuned-2.7.1-5.20170314git92d558b8.el7.noarch
    tuned-profiles-nfv-2.7.1-5.20170314git92d558b8.el7.noarch
FAIL
==============================================

# cat /etc/tuned/realtime-virtual-host-variables.conf 
isolated_cores=2,4-7

# tuned-adm profile realtime-virtual-host

# cat /var/log/tuned/tuned.log
...
2017-05-04 07:48:19,179 INFO     tuned.profiles.loader: loading profile: realtime-virtual-host
2017-05-04 07:48:19,183 INFO     tuned.daemon.daemon: starting tuning
2017-05-04 07:48:19,186 ERROR    tuned.units.manager: failed to initialize plugin scheduler
2017-05-04 07:48:19,187 ERROR    tuned.units.manager: __init__() takes exactly 8 arguments (9 given)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tuned/units/manager.py", line 50, in create
    plugin = self._plugins_repository.create(plugin_name)
  File "/usr/lib/python2.7/site-packages/tuned/plugins/repository.py", line 36, in create
    self._device_matcher_udev, self._plugin_instance_factory, self._global_cfg, self._variables)
TypeError: __init__() takes exactly 8 arguments (9 given)
2017-05-04 07:48:19,187 INFO     tuned.plugins.base: instance cpu: assigning devices cpu14, cpu15, cpu16, cpu17, cpu10, cpu11, cpu12, cpu13, cpu18, cpu19, cpu30, cpu31, cpu8, cpu9, cpu6, cpu7, cpu4, cpu5, cpu2, cpu3, cpu0, cpu1, cpu29, cpu28, cpu25, cpu24, cpu27, cpu26, cpu21, cpu20, cpu23, cpu22
...

Comment 11 errata-xmlrpc 2017-08-01 12:35:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2102


Note You need to log in before you can comment on or make changes to this bug.