Bug 143350 - ptrace horked in 2.6.9-1.1047_FC4smp
Summary: ptrace horked in 2.6.9-1.1047_FC4smp
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-19 21:16 UTC by Ulrich Drepper
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 21:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Drepper 2004-12-19 21:16:16 UTC
Description of problem:
ptrace() seems to be completely broken in 2.6.9-1.1047_FC4smp.

$ strace /bin/echo
execve("/bin/echo", ["/bin/echo"], [/* 39 vars */]) = 0

... and then it's stuck.  The process has to be aborted.  gdb shows the same
behavior.

Version-Release number of selected component (if applicable):
2.6.9-1.1047_FC4smp

How reproducible:
I haven't rebooted and don't know whether this has been the case ever since the
last boot, but it surely is 100% reproducible now.

Steps to Reproduce:
1.boot said kernel
2.strace /bin/echo
3.
  
Actual results:
Nothing except the fake execve message

Expected results:
trace

Additional info:
strace-4.5.8-1.x86_64 is used, but this shouldn't matter since gdb is also
affected and both programs worked before.

Comment 1 Ulrich Drepper 2004-12-20 02:37:47 UTC
This happens on x86 as well.  So not x86-64 specific.

Comment 2 Roland McGrath 2004-12-20 22:34:07 UTC
This is ok in the upstream kernel and in the RHEL4 kernel.
So it's just some sort of merging snafu or whatnot in the FC4 kernel.
I didn't see anything obvious.  I'm not going to worry about this since I figure
bleeding edge FC should be rebasing to 2.6.10(rc*) soon enough anyway.

Comment 3 Michal Jaegermann 2004-12-23 23:48:03 UTC
This got corrected a bit but in 2.6.9-1.1049_FC4 but not that much.
'strace echo' just prints, at least on x86_64,

execve("/bin/echo", ["echo"], [/* 24 vars */]) = 0

and returns.  I would expect to see some 38 lines of output.

Comment 4 Dave Jones 2005-01-04 17:47:51 UTC
theres a 2.6.10 based update in rawhide now, can you test that please ?

Comment 5 Ulrich Drepper 2005-01-04 21:00:01 UTC
Seems to work again in 2.6.10-based kernels.  I've only tested x86 so far, but
since the symptoms were identical this should apply to other archs as well.


Note You need to log in before you can comment on or make changes to this bug.