Bug 1433688 - tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix_dhcpv6_stateless failed on automation
tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix...
Status: CLOSED DUPLICATE of bug 1438662
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Assaf Muller
Toni Freger
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-19 06:45 EDT by Eran Kuris
Modified: 2017-04-04 02:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-04 02:03:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (184.64 KB, text/plain)
2017-03-19 06:45 EDT, Eran Kuris
no flags Details

  None (edit)
Description Eran Kuris 2017-03-19 06:45:08 EDT
Created attachment 1264602 [details]
log

Description of problem:
tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix_dhcpv6_stateless failed on our automation CI run 


attached log file
Version-Release number of selected component (if applicable):
python-neutron-lib-1.1.0-0.20170213120052.9b3ea8f.el7ost.noarch
openstack-neutron-ml2-10.0.0-5.el7ost.noarch
openstack-neutron-lbaas-10.0.1-0.20170222151526.c6011fb.el7ost.noarch
python-neutronclient-6.1.0-0.20170208193918.1a2820d.el7ost.noarch
openstack-neutron-common-10.0.0-5.el7ost.noarch
openstack-neutron-10.0.0-5.el7ost.noarch
openstack-neutron-openvswitch-10.0.0-5.el7ost.noarch
puppet-neutron-10.3.0-1.el7ost.noarch
python-neutron-10.0.0-5.el7ost.noarch
python-neutron-lbaas-10.0.1-0.20170222151526.c6011fb.el7ost.noarch

How reproducible:
Failed 2 times in the last 7 runs. Stability: 71 %

Steps to Reproduce:
1.Run tempest Neutron DFG CI job 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Eran Kuris 2017-04-03 04:04:15 EDT
tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_dhcp6_stateless_from_os

tempest.scenario.test_network_v6.TestGettingAddress.test_multi_prefix_slaac

This test failed with same error : 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 103, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 246, in test_dualnet_dhcp6_stateless_from_os
    self._prepare_and_test(address6_mode='dhcpv6-stateless', dualnet=True)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 161, in _prepare_and_test
    sshv4_1, ips_from_api_1, sid1 = self.prepare_server(networks=net_list)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 134, in prepare_server
    username=username)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 351, in get_remote_client
    linux_client.validate_authentication()
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/linux/remote_client.py", line 55, in wrapper
    six.reraise(*original_exception)
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/linux/remote_client.py", line 36, in wrapper
    return function(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/linux/remote_client.py", line 100, in validate_authentication
    self.ssh_client.test_connection_auth()
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/ssh.py", line 206, in test_connection_auth
    connection = self._get_ssh_connection()
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/ssh.py", line 120, in _get_ssh_connection
    password=self.password)
tempest.lib.exceptions.SSHTimeout: Connection to the 10.0.0.221 via SSH timed out.
User: cirros, Password: None


https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/RHOS/view/RHOS11/job/qe-DFG-neutron-11_director-rhel-7.3-virthost-1cont_2comp-ipv4-vxlan-lvm-lbaas/lastCompletedBuild/testReport/tempest.scenario.test_network_v6/TestGettingAddress/test_dualnet_dhcp6_stateless_from_os_compute_id_76f26acd_9688_42b4_bc3e_cd134c4cb09e_network_slow_/
Comment 3 Eran Kuris 2017-04-04 02:03:02 EDT

*** This bug has been marked as a duplicate of bug 1438662 ***

Note You need to log in before you can comment on or make changes to this bug.