Bug 1433733 - Role assignment via the GUI takes forever (until you hit F5)
Summary: Role assignment via the GUI takes forever (until you hit F5)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Jiri Tomasek
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-19 15:17 UTC by Udi
Modified: 2017-05-17 20:09 UTC (History)
8 users (show)

Fixed In Version: puppet-tripleo-6.3.0-9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:09:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 453127 None None None 2017-04-04 11:12:23 UTC
Launchpad 1672826 None None None 2017-04-04 11:02:18 UTC

Description Udi 2017-03-19 15:17:22 UTC
Description of problem:
When assigning nodes to roles via the GUI, the GUI never sees that the operation completed and keeps the user waiting forever.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-3.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Assign nodes to any role


Actual results:
The spinner spins forever.


Additional info:
This is a blocker for the automation.

Comment 1 Udi 2017-03-19 15:20:34 UTC
You see this in the browser console, right in the beginning when you click the assign button:

warning.js:36 Warning: setState(...): Can only update a mounted or mounting component. This usually means you called setState() on an unmounted component. This is a no-op. Please check the code for the Formsy(TableCheckBox) component.

Comment 5 Jiri Tomasek 2017-04-04 10:47:38 UTC
This should get fixed by https://review.openstack.org/#/c/452017

Comment 6 Ola Pavlenko 2017-04-04 11:12:23 UTC
fix proposed upstream in ocata/stable

Comment 7 Jiri Tomasek 2017-04-05 13:49:29 UTC
Fixed by https://review.openstack.org/#/c/453127/

Comment 10 Ola Pavlenko 2017-04-26 16:03:25 UTC
Verified: openstack-tripleo-ui-3.1.0-9.el7ost.noarch

Comment 11 errata-xmlrpc 2017-05-17 20:09:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.