Bug 1433888 - Restoration from online backup using "katello-restore <backup_directory>" command is failing.
Summary: Restoration from online backup using "katello-restore <backup_directory>" com...
Keywords:
Status: CLOSED DUPLICATE of bug 1431971
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Backup & Restore
Version: 6.2.8
Hardware: All
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact:
URL:
Whiteboard:
: 1439694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-20 10:02 UTC by Rajan Gupta
Modified: 2020-07-16 09:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-27 14:38:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 17908 0 None None None 2017-03-22 13:38:09 UTC

Description Rajan Gupta 2017-03-20 10:02:00 UTC
Description of problem:

Restoration from online backup using "katello-restore <backup_directory>" command is failing.

Version-Release number of selected component (if applicable): 
Red Hat Satellite 6.2.8


How reproducible & steps to reproduce:

katello-restore <backup_directory> : fails and gives error.


Actual results:

<output ommited>
Restoring backend data
tar (child): mongo_data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
tar (child): pgsql_data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
<output ommited>

Expected results:

Restore should be completed and ssystem's state should be restored.


Additional info:
Restoration from offline backup is fine but from online is failing.

Comment 2 Christine Fouant 2017-03-22 13:38:07 UTC
Connecting redmine issue http://projects.theforeman.org/issues/17908 from this bug

Comment 4 Christine Fouant 2017-03-24 19:05:50 UTC
(In reply to Rajan Gupta from comment #0)
> Description of problem:
> 
> Restoration from online backup using "katello-restore <backup_directory>"
> command is failing.
> 
> Version-Release number of selected component (if applicable): 
> Red Hat Satellite 6.2.8
> 
> 
> How reproducible & steps to reproduce:
> 
> katello-restore <backup_directory> : fails and gives error.
> 
> 
> Actual results:
> 
> <output ommited>
> Restoring backend data
> tar (child): mongo_data.tar.gz: Cannot open: No such file or directory
> tar (child): Error is not recoverable: exiting now
> tar: Child returned status 2
> tar: Error is not recoverable: exiting now
> tar (child): pgsql_data.tar.gz: Cannot open: No such file or directory
> tar (child): Error is not recoverable: exiting now
> tar: Child returned status 2
> tar: Error is not recoverable: exiting now
> <output ommited>
> 
> Expected results:
> 
> Restore should be completed and ssystem's state should be restored.
> 
> 
> Additional info:
> Restoration from offline backup is fine but from online is failing.

Please note - the files listed are only in offline backups. I think they have been reported backwards (restoration from OFFLINE backup fails with the tar errors, but ONLINE backups work)

Comment 5 Mike McCune 2017-04-27 14:38:17 UTC
This is caused by https://bugzilla.redhat.com/show_bug.cgi?id=1431971 which we are going to resolve ASAP. Going to close this bug as a dupe and cover the testing of a restore of offline backup in the above mentioned bug.

*** This bug has been marked as a duplicate of bug 1431971 ***

Comment 6 Christine Fouant 2017-05-22 15:34:14 UTC
*** Bug 1439694 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.