This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 143390 - iostat is unable to display device-mapper devices
iostat is unable to display device-mapper devices
Status: CLOSED DUPLICATE of bug 168483
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-20 05:42 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 11:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/diskstats (1.91 KB, text/plain)
2004-12-20 13:14 EST, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2004-12-20 05:42:20 EST
I have RAID-1 and datastorage on LVM2 (converted from LVM1 format). When using
"iostat", I'm able to see IO statistic for md0, md1, every hd[a-z] but not whole
LVM evn there is active and mounted LV on it. When trying to monitor only LVM
device, there is zero activity even there is /sys/block/dm-0 (with zeroes).

I'm able to see strange values for md0 and md1 too. md0 has only 2/3 of hda and
hdc (even they are dedicated for RAID-1 [md0 and md1]):

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
hda               1,33         0,00        15,95          0         48
hdc               1,33         0,00        15,95          0         48
md0               1,33         0,00        10,63          0         32
md1               0,00         0,00         0,00          0          0

Expected result: Ability to monitor IO in systemon all devices (RHEL4b2).
Comment 1 Charlie Bennett 2004-12-20 13:01:14 EST
hi - can you attach a copy of your /proc/diskstats?

Thanks
ccb
Comment 2 Milan Kerslager 2004-12-20 13:14:37 EST
Created attachment 108913 [details]
/proc/diskstats
Comment 3 Jay Turner 2005-01-14 09:37:32 EST
Back to assigned.
Comment 4 Charlie Bennett 2005-02-01 15:45:56 EST
The kernel does not report partition information for lvm devices in
/proc/diskstats.  Sysstat cannot report information it doesn't have.

I'll push this to the attention of the kernel group.
Comment 5 Alasdair Kergon 2005-11-16 11:28:52 EST

*** This bug has been marked as a duplicate of 168483 ***

Note You need to log in before you can comment on or make changes to this bug.