Bug 1433937 - virt-inspector can't get icon info from altlinux-centaurus
Summary: virt-inspector can't get icon info from altlinux-centaurus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-20 12:17 UTC by Xianghua Chen
Modified: 2017-08-01 22:13 UTC (History)
3 users (show)

Fixed In Version: libguestfs-1.36.3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:13:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description Xianghua Chen 2017-03-20 12:17:06 UTC
Description of problem:
virt-inspector can't get icon info from altlinux-centaurus.

Version-Release number of selected component (if applicable):
virt-dib-1.36.2-2.el7.x86_64

How reproducible:
100%

Steps:
1. Prepare one altlinux-centaurus guest image:
altlinux-centaurus-x86_64.qcow2
2. Inspect it:
# virt-inspector -a altlinux-centaurus-x86_64.qcow2


Actual results:
There is no icon info like:
<icon>... ... </icon>


Expected results:
There should be icon info in the xml output.


Additional info:

Comment 1 Xianghua Chen 2017-03-20 12:20:06 UTC
Sorry, the version should be:

Version-Release number of selected component (if applicable):
libguestfs-1.36.2-2.el7.x86_64

Comment 2 Pino Toscano 2017-03-20 12:52:22 UTC
Easy fix, luckly there are logos also in other system packages -- patch posted:
  https://www.redhat.com/archives/libguestfs/2017-March/msg00222.html

Comment 3 Pino Toscano 2017-03-20 13:28:51 UTC
Fixed with
https://github.com/libguestfs/libguestfs/commit/bc54e0d605682385f460c6e90ba87c5a48f8077e
which is in libguestfs >= 1.37.7.

Comment 5 Xianghua Chen 2017-03-24 06:02:09 UTC
Failed with the following package:
libguestfs-1.36.2-3.el7.x86_64

Steps:
1. Prepare one altlinux-centaurus guest image:
altlinux-centaurus-x86_64.qcow2
2. Inspect it:
# virt-inspector -a altlinux-centaurus-x86_64.qcow2

Still no <icon>. 
Also failed for altlinux-simply-x86_64.qcow2 this time.

P.S.:
I have checked the patch that you are using: /usr/share/icons/hicolor/64x64/apps/altlinux.png
But actually there is no that file, I guestmount it and find that there are only:
# find /mnt/test/usr/share/icons/hicolor/  -name altlinux.png
/mnt/test/usr/share/icons/hicolor/32x32/apps/altlinux.png
/mnt/test/usr/share/icons/hicolor/16x16/apps/altlinux.png
/mnt/test/usr/share/icons/hicolor/48x48/apps/altlinux.png

So does the altlinux-simply image.

Comment 6 YongkuiGuo 2017-03-28 03:19:14 UTC
Verified with package:
libguestfs-1.36.3-1.el7.x86_64

Steps:
1. Prepare one altlinux-centaurus guest image:
altlinux-centaurus-x86_64.qcow2
2. Inspect it:
# virt-inspector -a altlinux-centaurus-x86_64.qcow2

Actual results:
<icon>iVBORw0KGgoAAAANSUhEUgAAADAAAAAwCAYAAAB
...
YACKAh7wGAAAMAtadvwYjEQmYAAAAASUVORK5CYII=</icon>

There is icon info in the xml output. So does the altlinux-simply image.
So verified.

Comment 7 errata-xmlrpc 2017-08-01 22:13:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.