Bug 1434025 - [VMWARE]Auto_placement provision fails due to selecting Host in Maintenance state
Summary: [VMWARE]Auto_placement provision fails due to selecting Host in Maintenance s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.0
Assignee: William Fitzgerald
QA Contact: Alex Newman
URL:
Whiteboard: vmware:provision
Depends On:
Blocks: 1438865 1438866 1452820
TreeView+ depends on / blocked
 
Reported: 2017-03-20 15:03 UTC by Leo Khomenko
Modified: 2018-03-06 15:17 UTC (History)
7 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1438865 1438866 1452820 (view as bug list)
Environment:
Last Closed: 2018-03-06 15:17:22 UTC
Category: ---
Cloudforms Team: VMware
Target Upstream Version:


Attachments (Terms of Use)

Description Leo Khomenko 2017-03-20 15:03:06 UTC
Description of problem:Environment setup - best fitting Host in Maintenance mode (lowest amount of VM is 0) and other Hosts should have at least 1 VM


Version-Release number of selected component (if applicable):5.7.1.3


How reproducible:100%


Steps to Reproduce:
1.Prepare env
2.Provision VM with auto_placement

Actual results: Provision fails due to Provider failure - 
"Message [Error: Cannot complete file creation operation.]"


Expected results: "Maintenance" Host should not be selected


Additional info: Manual provision to such Host also fails with the same error.

Comment 4 Greg McCullough 2017-03-23 14:45:08 UTC
Host already contains a "maintenance" column, the best-fit logic for all infra providers should skip hosts that are in maintenance mode.

Comment 5 William Fitzgerald 2017-03-30 13:54:13 UTC
Recreated problem and working on a fix

Comment 6 William Fitzgerald 2017-04-04 12:33:08 UTC
https://github.com/ManageIQ/manageiq-content/pull/81


Note You need to log in before you can comment on or make changes to this bug.