Bug 1434040 - Offload upload package profile to dynflow executor
Summary: Offload upload package profile to dynflow executor
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management   
(Show other bugs)
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.2
Assignee: Shimon Shtein
QA Contact: Roman Plevka
URL:
Whiteboard: scale_lab
Keywords: PrioBumpField, PrioBumpPM, Triaged
: 1434220 (view as bug list)
Depends On:
Blocks: 1353215 sat6-fe-walmart
TreeView+ depends on / blocked
 
Reported: 2017-03-20 15:32 UTC by Mike McCune
Modified: 2018-12-06 20:45 UTC (History)
15 users (show)

Fixed In Version: rubygem-katello-3.0.0.143-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1463805 (view as bug list)
Environment:
Last Closed: 2017-08-10 17:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hotfix RPM (6.07 MB, application/x-gzip)
2017-03-21 02:29 UTC, Eric Helms
no flags Details
Updated hotfix RPMs (3.69 MB, application/x-gzip)
2017-03-22 03:42 UTC, Eric Helms
no flags Details
Satellite 6.2.9 hotfix (4.88 MB, application/x-rpm)
2017-06-09 14:32 UTC, Andrew Kofink
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2466 normal SHIPPED_LIVE Satellite 6.2.11 Async Release 2017-08-10 21:01:20 UTC
Foreman Issue Tracker 18682 None None None 2017-03-20 15:32 UTC

Description Mike McCune 2017-03-20 15:32:32 UTC
Right now the controller parses packages JSON and plans the action. The problem is that the planning phase is quite long, so the action stays in memory for a long time. This causes GC to mark the JSON as old, so this parameter will stay in memory for a long time causing memory fragmentation.

Comment 1 Mike McCune 2017-03-20 15:32:36 UTC
Created from redmine issue http://projects.theforeman.org/issues/18682

Comment 2 Mike McCune 2017-03-20 15:32:40 UTC
Upstream bug assigned to sshtein@redhat.com

Comment 4 Eric Helms 2017-03-21 02:29 UTC
Created attachment 1264895 [details]
Hotfix RPM

Comment 5 Pradeep Kumar Surisetty 2017-03-21 13:13:18 UTC
*** Bug 1434220 has been marked as a duplicate of this bug. ***

Comment 7 Eric Helms 2017-03-22 03:42 UTC
Created attachment 1265287 [details]
Updated hotfix RPMs

Comment 11 pm-sat@redhat.com 2017-05-03 00:11:59 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18682 has been resolved.

Comment 13 Andrew Kofink 2017-06-09 14:32 UTC
Created attachment 1286424 [details]
Satellite 6.2.9 hotfix

This is the hotfix for Satellite 6.2.9

Comment 16 Roman Plevka 2017-08-02 14:16:12 UTC
VERIFIED
for 6.2.11-2

Comment 18 errata-xmlrpc 2017-08-10 17:02:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2466


Note You need to log in before you can comment on or make changes to this bug.