Bug 1434242 - Upstream image reference in deploy heketi
Summary: Upstream image reference in deploy heketi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: CNS 3.5
Assignee: Raghavendra Talur
QA Contact: Apeksha
URL:
Whiteboard:
Depends On:
Blocks: 1415600
TreeView+ depends on / blocked
 
Reported: 2017-03-21 05:01 UTC by Mohamed Ashiq
Modified: 2018-12-06 19:58 UTC (History)
6 users (show)

Fixed In Version: cns-deploy-4.0.0-5.el7rhgs.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:28:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Mohamed Ashiq 2017-03-21 05:01:40 UTC
Description of problem:
Deploy heketi template has upstream image reference in templates.

        - name: deploy-heketi
          image: heketi/heketi:dev


Version-Release number of selected component (if applicable):
cns-deploy-4.0.0-4.el7rhgs.x86_64

How reproducible:
Always

Actual results:
          image: heketi/heketi:dev

Expected results:
          image: rhgs3/rhgs-volmanager-rhel7:3.2.0-2

Comment 5 Raghavendra Talur 2017-03-21 09:32:31 UTC
FYI,

This bug requires updating of image names in both Heketi and cns-deploy packages.

Comment 8 Apeksha 2017-03-28 07:09:41 UTC
heketi image name now points to:
- name: heketi
  image: rhgs3/rhgs-volmanager-rhel7:3.2.0-4

Verified in build - cns-deploy-4.0.0-9.el7rhgs.x86_64

Comment 9 errata-xmlrpc 2017-04-20 18:28:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112

Comment 10 vinutha 2018-12-06 19:58:58 UTC
Marking qe-test-coverage as - since the preferred mode of deployment is using ansible


Note You need to log in before you can comment on or make changes to this bug.