Bug 1434335 - Errors log filled with attrlist_replace - attr_replace (nsslapd-referral, ldap://<host>:389/o%3Dipaca) failed.
Summary: Errors log filled with attrlist_replace - attr_replace (nsslapd-referral, lda...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base   
(Show other bugs)
Version: 7.4
Hardware: Unspecified Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Ludwig
QA Contact: Viktor Ashirov
Marc Muehlfeld
URL:
Whiteboard:
Keywords: Reopened, ZStream
Depends On:
Blocks: 1499668
TreeView+ depends on / blocked
 
Reported: 2017-03-21 10:07 UTC by German Parente
Modified: 2018-04-10 14:16 UTC (History)
7 users (show)

Fixed In Version: 389-ds-base-1.3.7.5-5.el7
Doc Type: Bug Fix
Doc Text:
Directory Server no longer logs an error if not running the "cleanallruv" task After removing a replica server from an existing replication topology without running the "cleanallruv" task, Directory Server previously logged an error about not being able to replace referral entries. This update adds a check for duplicate referrals and removes them. As a result, the error is no longer logged.
Story Points: ---
Clone Of:
: 1499668 (view as bug list)
Environment:
Last Closed: 2018-04-10 14:15:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 14:16 UTC

Description German Parente 2017-03-21 10:07:02 UTC
Description of problem:

This problem was fixed in:

https://bugzilla.redhat.com/show_bug.cgi?id=1288229
many attrlist_replace errors in connection with cleanallruv

but has re-appeared in this new version. I know it's harmless but it's preventing to read the logs and to find information.

I have checked the patch in:

https://pagure.io/389-ds-base/issue/48283

and it's included in the master branch.


Version-Release number of selected component (if applicable): 

389-ds-base-1.3.5.10-15.el7_3.x86_64


How reproducible: in lots of customers and even locally when there are invalid ruvs.

Comment 2 mreynolds 2017-03-21 19:57:02 UTC
Upstream ticket:
https://pagure.io/389-ds-base/issue/49180

Comment 3 mreynolds 2017-03-28 19:02:00 UTC
German, how do you reproduce this exactly?  Thanks!

Comment 10 mreynolds 2017-05-04 15:08:20 UTC
Closing for now until a reproducer is found

Comment 11 German Parente 2017-09-18 14:35:36 UTC
We are seeing these errors again in all the customers.

in 7.4 version.

Please, investigate this because customers are asking support to clean the ruvs all the time only because of these errors.

Or eventually, log a warning since it's not an issue.

Comment 12 Viktor Ashirov 2017-09-18 17:23:03 UTC
Re-opening per c#11 for investigation.

Comment 14 Ludwig 2017-09-22 08:56:22 UTC
bug 1288229 fixed a real bug in managing nsds50ruv  with many elements which could lead to invalid duplicate values and as a consequence to attrlist_replace errors for nsds50ruv attribute.

This bug is about nsslapd-referral and I think it is not a real bug, but a consequence of bad RUVs. I have not yet written a reproducer, but from my analysis I think this is what happens.

In a replication session the nsslapd-referrals in the mapping tree entry are updated based on the supplier ruv.
The nsslapd-referral only uses the URL ignorig the replicaid
If a ruv contains the same URL with different replicaids the generated list of referrals will contain duplicate urls and so lead to the attrlist_replace error.

Cleaning the RUV should prevent further occurrence of these messages.

But we could enhance the replication code to strip duplicate urls before updating the referrals, hiding problems with invalid ruvs

Comment 20 Viktor Ashirov 2017-11-02 14:22:08 UTC
===================================================================== test session starts =====================================================================
platform linux -- Python 3.5.1, pytest-3.2.3, py-1.4.34, pluggy-0.4.0 -- /opt/rh/rh-python35/root/usr/bin/python3
cachedir: .cache
metadata: {'Platform': 'Linux-3.10.0-748.el7.x86_64-x86_64-with-redhat-7.5-Maipo', 'Plugins': {'metadata': '1.5.0', 'html': '1.16.0'}, 'Python': '3.5.1', 'Packages': {'pluggy': '0.4.0', 'py': '1.4.34', 'pytest': '3.2.3'}}
389-ds-base: 1.3.7.5-6.el7
nss: 3.33.0-1.el7
nspr: 4.17.0-1.el7
openldap: 2.4.44-5.el7
svrcore: 4.1.3-2.el7

rootdir: /export/tests, inifile:
plugins: metadata-1.5.0, html-1.16.0
collected 1 item                                                                                                                                               

tickets/ticket49180_test.py::test_ticket49180 PASSED

------------------------------------------------ generated xml file: /mnt/tests/rhds/tests/upstream/report.xml ------------------------------------------------
----------------------------------------------- generated html file: /mnt/tests/rhds/tests/upstream/report.html -----------------------------------------------
================================================================= 1 passed in 136.98 seconds ==================================================================

Automated test passed, marking as VERIFIED.

Comment 23 errata-xmlrpc 2018-04-10 14:15:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811


Note You need to log in before you can comment on or make changes to this bug.