Bug 1434374 - openstack-status tries to use the keystone named python cli client
Summary: openstack-status tries to use the keystone named python cli client
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-utils
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Alan Pevec
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-21 11:36 UTC by Attila Fazekas
Modified: 2017-05-17 20:10 UTC (History)
2 users (show)

Fixed In Version: openstack-utils-2017.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:10:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Attila Fazekas 2017-03-21 11:36:20 UTC
Description of problem:
When you have sourced openstack credentials the script fails with:
/usr/bin/openstack-status: line 267: keystone: command not found

python-keystoneclient is installed, but does not provides cli entry,
because is was deprecated then got removed in favor of the unified `openstack` client.

Version-Release number of selected component (if applicable):
2016.1-1.el7ost

How reproducible:
always


Expected results:
either remove the user display function,
or make it working.


Additional info:
Not just 11.

Comment 1 Alan Pevec 2017-03-23 01:35:38 UTC
In RDO common-testing, will be picked up by the next OSP import.
If impatient take it from http://cbs.centos.org/kojifiles/packages/openstack-utils/2017.1/1.el7/noarch/openstack-utils-2017.1-1.el7.noarch.rpm

Comment 3 errata-xmlrpc 2017-05-17 20:10:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.