Bug 143439 - gulm cannot be used to lock clvmd
Summary: gulm cannot be used to lock clvmd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-20 20:55 UTC by Corey Marthaler
Modified: 2010-01-12 04:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 22:29:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2004-12-20 20:55:48 UTC
Description of problem:
[root@morph-01 root]# cat /proc/cluster/nodes
Node  Votes Exp Sts  Name
   1    1    6   M   morph-04
   2    1    6   M   morph-05
   3    1    6   M   morph-06
   4    1    6   M   morph-03
   5    1    6   M   morph-02
   6    1    6   M   morph-01

[root@morph-01 root]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           1   2 run       -
[1 6 4 3 2 5]

[root@morph-01 root]# lock_gulmd -s morph-01,morph-03,morph-05 -n
morph-cluster


[root@morph-01 root]# gulm_tool getstats morph-01
I_am = Master
quorum_has = 3
quorum_needs = 2
rank = 0
quorate = true
GenerationID = 1103575624978377
run time = 343
pid = 2225
verbosity = Default
failover = enabled


[root@morph-01 root]# clvmd
clvmd could not connect to cluster manager
Consult syslog for more information

SYSLOG:
Dec 20 14:49:22 morph-01 clvmd: Unable to create lockspace for CLVM:
No such device


Version-Release number of selected component (if applicable):
Dec 20 14:42:53 morph-01 kernel: Gulm <CVS> (built Dec 20 2004
13:23:01) installed


How reproducible:
Always

Comment 1 Derek Anderson 2004-12-21 17:30:12 UTC
FWIW, you can get clvmd to start by removing /dev/misc/dlm-control. 
Good times.  I noticed this testing GNBD too.

[root@link-10 root]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           1   2 run       -
[1 3 2]

[root@link-10 root]# lock_gulmd -s link-10,link-11,link-12 -n MILTON
[root@link-10 root]# gulm_tool getstats link-10
I_am = Arbitrating
quorum_has = 1
quorum_needs = 2
rank = 0
quorate = false
GenerationID = 1103650138075131
run time = 9
pid = 4415
verbosity = Default
failover = enabled
[root@link-10 root]# clvmd
clvmd could not connect to cluster manager
Consult syslog for more information
[root@link-10 root]# rm /dev/misc/dlm-control
rm: remove character special file `/dev/misc/dlm-control'? y
[root@link-10 root]# clvmd
[root@link-10 root]#

Comment 2 Derek Anderson 2004-12-21 17:56:09 UTC
Oh, Side_show_ Bob.  A little confusion on this.

I was thinking of running a GuLM locked filesystem on top of CLVMD
(which was in turn locked by dlm).  That works just fine.  The issue
here is using GuLM as the lock manager for CLVM itself; nothing to do
with the filesystem running on top of it.

Comment 3 Corey Marthaler 2004-12-21 17:57:10 UTC
to clarify...

dlm locking clvm = good
gulm locking clvm = bad
dlm locking clvm AND gulm lock GFS = good

Comment 4 Corey Marthaler 2004-12-21 18:02:34 UTC
when built with ./configure --with-clvmd=gulm --with-cluster=shared

what happens is that clvmd starts but the first thing to attempt a
lock (like vgchange) hangs.





Comment 5 Corey Marthaler 2004-12-21 18:04:09 UTC
one more thing...

thus, the clvm lock manager type should be a run time option rather
than a compile time option.

Comment 6 Adam "mantis" Manthei 2004-12-21 18:26:50 UTC
Derek, The behavior that you mentioned in comment #1 should be fixed
now (see bug #138491)

Comment 7 Christine Caulfield 2005-01-04 13:13:42 UTC
It sounds like the daemon hasn't built correctly and there are bits of
DLM and bits of GULM in it. Was this from a clean source tree ?

Can you build it with DEBUG enabled and run it -d, then attach the
output please.

Comment 8 Christine Caulfield 2005-01-04 15:13:00 UTC
Stupid typo

clvmd was ignoring the first node in ccs, it works for me now.

Checking in daemons/clvmd/clvmd-gulm.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd-gulm.c,v  <--  clvmd-gulm.c
new revision: 1.4; previous revision: 1.3
done


Comment 9 Corey Marthaler 2005-01-27 22:29:53 UTC
fix verified.


Note You need to log in before you can comment on or make changes to this bug.