Bug 14344 - XFree 4.0.1 had bug in ati server. Patch to correct here.
XFree 4.0.1 had bug in ati server. Patch to correct here.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
ftp://ftp.ox.ac.uk/pub/users/adrian/X...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-20 17:43 EDT by adrian.lawrence
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-21 10:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description adrian.lawrence 2000-07-20 17:43:14 EDT
Xfree 4.0.1 crashed on a machine using an old Mach32 graphics card. The
problem was
debugged and fixed with Marc Aurele La France, the author of the driver.
A patch to correct the problem is here:
ftp://ftp.ox.ac.uk/pub/users/adrian/XFree86-4.0.1-ati.patch .

There is also a spec file (a bit flakey, designed to work on Redhat 6.2
with rpm 3.0.4 rather than Rawhide) here:
ftp://ftp.ox.ac.uk/pub/users/adrian/XFree86.spec . It include a few mods
concerning which fiiles are configuration. In particular, it does *not*
overwrite /etc/X11/XF86Config which is a very unpleasant feature of the
current Rawhide version :-(

The rpm built as above and installed under RH6.2 have been tested on 3
different machines with 3 different architectures and graphics families and
work on all.

ael
Comment 1 adrian.lawrence 2000-07-20 18:09:28 EDT
Sorry: this refers to XFree86 and friends, not to XFree86-Servers. Apologies.
ael
Comment 2 Bill Nottingham 2000-08-14 17:31:08 EDT
This will be fixed in XFree86-4.0.1-0.44. Thanks for the patch!
Comment 3 adrian.lawrence 2000-11-04 04:31:58 EST
Redhat 7.0 XFree86 upgrade again erased a carefully handcrafted XF86Config, so
the 2nd point above is outstanding.

Also XFree86-4.0.1-1 again crashes on a Mach32 with sig 11. I am downloading the
source as I type tosee if the ati patch above has been applied, but it looks
like the same problem.
Comment 4 adrian.lawrence 2000-11-04 09:28:32 EST
The ati patch *is* in XFree86-4.0.1-1, so this appears to be a new bug. I will
enter it as a new report against Redhat 7.0. For the moment, all I have is a
log: I have not investigated further.

Note You need to log in before you can comment on or make changes to this bug.