Bug 143444 - xscreensaver-4.10-skip-unavailable-hacks.patch is unnecessary
Summary: xscreensaver-4.10-skip-unavailable-hacks.patch is unnecessary
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xscreensaver   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-20 23:32 UTC by Jamie Zawinski
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:10:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jamie Zawinski 2004-12-20 23:32:06 UTC
This patch (included with xscreensaver-4.10-8.src.rpm from
updates/enterprise/3desktop/) is apparently intended to omit
uninstalled programs from the list in xscreensaver-demo --
but that's what the "ignoreUninstalledPrograms" preference
does.

You already set "ignoreUninstalledPrograms: True" in 
xscreensaver-4.06-rh.patch, so 
xscreensaver-4.10-skip-unavailable-hacks.patch is redundant.

The only effect that the latter patch has is to make it
impossible for users to set"ignoreUninstalledPrograms"
to False, if that's what they prefer.

Comment 1 RHEL Product and Program Management 2007-10-19 19:10:49 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.