Bug 143445 - xscreensaver-4.10-prune-hack-list.patch is bogus
xscreensaver-4.10-prune-hack-list.patch is bogus
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xscreensaver (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-20 18:43 EST by Jamie Zawinski
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xscreensaver-4.10-webcollage-warning.patch (1.79 KB, patch)
2005-01-04 09:33 EST, Panu Ervamaa
no flags Details | Diff

  None (edit)
Description Jamie Zawinski 2004-12-20 18:43:22 EST
This patch (included with xscreensaver-4.10-8.src.rpm from
updates/enterprise/3desktop/) causes the "webcollage" and
"webcollage-helper" programs to not be compiled or installed.

This patch is wrong for two reasons:

  1:  when there is a program that you don't want people to be
      shown by default for some reason, you should just disable
      it in XScreenSaver.ad.in (you already do this for "bsod",
      for example.)

  2:  webcollage is *already* disabled by default, in both the
      upstream xscreensaver and in your copy of 4.10.

All this patch does is make it impossible for people to run
webcollage even if they know that they want to.

I gather this is related to bug 130253, but I do not have permission
to view that bug (why's that?)
Comment 1 Ray Strode [halfline] 2005-01-03 09:21:12 EST
Hi,

I think the problem is that users are re-enabling it, not realizing
that it could potentially render offensive/inappropriate content on
their screens.  As I understand it, this has caused more than a few
people embarrassment in the workplace.

The easiest solution to this problem was to remove the screensaver. 
That seemed like the best solution for RHEL3 and RHEL4 given time
constraints.  It doesn't seem like an unreasonable solution for Fedora
either.
Comment 2 Jamie Zawinski 2005-01-03 19:36:48 EST
How about if I changed the description in webcollage.xml to say
"DANGER, THE INTERNET SOMETIMES CONTAINS PR0N" or something?

Right now your patch both removes it entirely from the .ad file, and
also doesn't install it.  I think that there's no reason to do the
latter (if it's not in the .ad file, it won't be in the list unless
someone adds it to their ~/.xscreensaver file by hand.)
Comment 3 Jamie Zawinski 2005-01-03 19:44:59 EST
e.g.,

--- config/webcollage.xml	26 Apr 2004 06:46:41 -0000	1.4
+++ config/webcollage.xml	4 Jan 2005 00:43:47 -0000
@@ -26,8 +26,12 @@
 up to filter the images through the `VidWhacker' program, above, which
 looks really great.
 
-(Note that most of the images it finds are text, and not pictures.
-This is because most of the web is pictures of text.  Which is pretty
-sad.)  Written by Jamie Zawinski.
+WARNING: THE INTERNET SOMETIMES CONTAINS PORNOGRAPHY.
+
+The Internet being what it is, absolutely anything might show up in the
+collage including -- quite possibly -- pornography, or even nudity.
+Please act accordingly.
+
+Written by Jamie Zawinski.
   </_description>
 </screensaver>
Comment 4 Panu Ervamaa 2005-01-04 09:33:11 EST
Created attachment 109326 [details]
xscreensaver-4.10-webcollage-warning.patch

This patch adds a "-disable" option to the webcollage executable, and a
corresponding checkbox at the configuration editor.
Comment 5 Panu Ervamaa 2005-01-04 09:37:00 EST
xscreensaver-4.10-webcollage-warning.patch makes
xscreensaver-4.10-prune-hack-list.patch obsolete and should solve the
original problem.
Comment 6 RHEL Product and Program Management 2007-10-19 15:10:46 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.