This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 143446 - Disable "Device not ready. Make sure there is a disc in the drive." messages
Disable "Device not ready. Make sure there is a disc in the drive." messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-20 18:44 EST by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 08:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kernel patch againg "device not ready" with Yamaha SCSI devs (1.07 KB, patch)
2004-12-23 04:21 EST, Ville Steudle
no flags Details | Diff

  None (edit)
Description Ralf Ertzinger 2004-12-20 18:44:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041216 Firefox/1.0 Fedora/1.0-6

Description of problem:
When accessing a SCSI drive without media (IDE seems unaffected), the
kernel prints "Device not ready.  Make sure there is a disc in the
drive." to the kernel log. This gets quite annoying when running a
normal desktop with hal and whatnot checking on the drives every
second (having multiple SCSI drives does not help, either).

I think these messages ought to be disabled.

Version-Release number of selected component (if applicable):
2.6.9-1.1047_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot desktop system with SCSI CD drives
2. watch syslog
3.
    

Actual Results:  Multiple "no disk" messages

Expected Results:  Suppression of useless message

Additional info:
Comment 1 Ville Steudle 2004-12-23 04:19:43 EST
(added this also to #130649 which might be related):

When analyzing why my Yamaha 4260 (older SCSI writer) causes "Device 
not ready" kernel messages in the log with FC3 while my SCSI DVD does 
not, I noticed this detail:

The SCSI command that triggers the NOT_READY answer for the Yamaha 
seems to be ALLOW_MEDIUM_REMOVAL, not TEST_UNIT_READY.

After applying the kernel patch below, the kernel got quiet.

Note that this cures only a symptom, I did not analyze the root 
cause, i.e. look for the application issueing this command.
Comment 2 Ville Steudle 2004-12-23 04:21:23 EST
Created attachment 109068 [details]
Kernel patch againg "device not ready" with Yamaha SCSI devs

Suppresses the "Device not ready" kernel message in scsi_ioctl.c not only as
response to TEST_UNIT_READY (as in the original kernel), but also for
ALLOW_MEDIUM_REMOVAL.
Comment 3 Ralf Ertzinger 2004-12-23 07:45:42 EST
I have the same writer attached to the bus, and indeed, putting a CD
in the drive makes the messages stop (although other SCSI drives and
IDE drives are still empty).
Sorry for the confusion.

Maybe it would be helpful to indicate which drive caused the message :)
Comment 4 Henning Schmiedehausen 2005-02-11 06:50:19 EST
I wholeheartedly support this request. Getting this message every second in my
logs is really annoying. 

It seems that SCSI DVD drives and SCSI CD Burners are not that popular any more.

Behaviour observed with

Host: scsi0 Channel: 00 Id: 03 Lun: 00
  Vendor: TOSHIBA  Model: DVD-ROM SD-M1201 Rev: 1011
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: YAMAHA   Model: CRW8824S         Rev: 1.00
  Type:   CD-ROM                           ANSI SCSI revision: 02
Comment 5 Ralf Ertzinger 2005-11-28 08:07:54 EST
These seem to have disappeared within rawhide for some time now.

Note You need to log in before you can comment on or make changes to this bug.