Bug 143451 - Update sk98lin driver in kernel
Update sk98lin driver in kernel
Status: CLOSED DUPLICATE of bug 143478
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
http://www.smc.com/index.cfm?event=vi...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-20 20:02 EST by Jay Lee
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 10:33:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Lee 2004-12-20 20:02:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The sk98lin driver contained in the current RHEL3 U4 kernel is
outdated and does not support a large number of newer devices that use
an updated version of the syskonnect gigabit network chips.  Devices
which do not work include the SMC EZCard Gigabit PCI Card (commonly
found at CompUSA or other retailers) and the built in ethernet on
motherboards like the ABIT KV8 also commonly available.  Syskonnect
appears to maintain the driver and offer it under the GPL via their
website.  The version included in RHEL3 is 6.02.  Vanilla kernels
2.4.28 and 2.6.9 use 6.21 and 6.23 respectively which seem to support
newer versions of the network chipset.  The current 7.09 driver from
Syskonnect works flawlessly with all network cards I've tested as well
as offering additional features.  Kindly consider upgrading this
driver with the next kernel update so that RHEL3 will support a
broader range of modern gigabit ethernet cards.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.EL

How reproducible:
Always

Steps to Reproduce:
1.  Install RHEL3 U4 on a system with a newer sk98lin based network
card such as the SMC EZ card 1000 (SMC9452TX part #99-012084-215).

2.  Kudzo does not detect NIC, no driver installed

3.  Forcing sk98lin.o module to load reports no card found.

4.  Download v7.09 driver from syskonnects website
(http://www.syskonnect.com/syskonnect/support/driver/d0102_driver.html)

5.  Compile and install

6.  NIC is detected and fully functional    

Actual Results:  Network Card is not detected and usable by RHEL3
kernel sk98lin.o module

Expected Results:  Network card should be functional

Additional info:

lspci output on system with SMC9452TX NIC:

[root@www /]# lspci -vv -d 11ab:4320
02:0b.0 Ethernet controller: Marvell Technology Group Ltd. Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter (rev 12)
        Subsystem: Standard Microsystems Corp [SMC]: Unknown device b452
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (5750ns min, 7750ns max), cache line size 08
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at feafc000 (32-bit, non-prefetchable) [size=16K]
        Region 1: I/O ports at d800 [size=256]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [50] Vital Product Data
Comment 1 Ernie Petrides 2004-12-20 20:42:48 EST
I'm reassigning this to Product Management, since the sk98lin
network driver is currently unsupported.  This is essentially
a feature request (to support and update the driver).
Comment 3 Robert Perkins 2005-01-05 10:33:07 EST
Closing since we are tracking this as a FZ.

*** This bug has been marked as a duplicate of 143478 ***
Comment 4 Jonathan Peatfield 2005-05-19 22:22:10 EDT
Just in case you hadn't already noticed, Intel seem to be including a Marvel
Yukon based network device on some of their recent (and therefore increasingly
common) boards (I'm frankly surprised by this since it must cost them more than
using their own e1000 design but who can tell).

e.g. on at least one D915G board we have the following pci device:

04:00.0 Ethernet controller: Marvell Technology Group Ltd. Gigabit Ethernet
Controller (rev 17)
04:00.0 Class 0200: 11ab:4361 (rev 17)

The sk98lin driver in RHEL4 doesn't seem to like it either.

I'd add this comment to the bug #143478 that this has been marked a duplicate
of, but that one isn't public so I can't.
Comment 5 Bill Muller 2007-05-09 19:52:49 EDT
It is quite frustrating to see that this entry has been marked closed with a
resolution of "DUPLICATE of bug 143478" and then find that I am denied access to
bug 143478.  Entries should not be closed and marked duplicates if they are
duplicates of private entries.

Note You need to log in before you can comment on or make changes to this bug.