Bug 143453 - sounds apps regularly lock up under stock fedora core 3
sounds apps regularly lock up under stock fedora core 3
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2004-12-20 20:38 EST by Wayne Schuller
Modified: 2013-03-13 00:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-21 11:20:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Wayne Schuller 2004-12-20 20:38:40 EST
Description of problem:
Sound related apps, especially rhythmbox (rb), regularly "freeze"
under stock fedora core 3.
Comment 1 Wayne Schuller 2004-12-20 20:41:47 EST
Some more comments:

If I run rb, totem or xmms or some other sound related programs,
sometimes it will have sound, other times it just locks up. I then
need to click on the "X" on the title bar (to close window) and wait
for gnome-session (or is it the window manager?) to give me the
opportunity to kill the app because it is not responding.

rb especially locks up very often when changing to a new song. very
rarely will rb give an error message (eg: "unable to connect to sound

this really makes all sound related apps unusable, it is like they are
fighting for control of the sound card.

under old versions of redhat and fedora that weren't alsa based, this
didn't happen. So this may be an ALSA related bug. My guess it is the
combination of ALSA and esd.

My PC is a 6 year old Celeron 450MhZ, 328mb ram, and an Ensoniq Audio
pci sound card.

When I run system-config-soundcard: it reports I have an Ensoniq
ES1370 (AudioPCI) - this is correct. It says it is using the
snd-ens1370 kernel module. I CAN hear the test sound when I click on
the button for the test. BUT if I am already running a working rb,
then when I click on the "test sound button" then
system-config-soundcard "freezes up", just as rb does when another
application has control of the sound. It stays frozen until the next
song in rb is finished, at which point the soundcard config tool
unfreezes and plays its sound.

Could it be that in the "old days", I thought esd did all the mixing
in software, but now alsa is assuming modern sound card hardware which
has hardware based mixing, and my sound card doesn't support that? 
or is it a bug with the snd-ens1370 kernel module?

Comment 2 Sitsofe Wheeler 2004-12-21 05:30:02 EST
esd still does mixing but only if you tell a program to use it. For
rhythmbox you have to set gstreamer to use esd (run
gstreamer-properties and set the output to "ESD - Enlightment
Sound Daemon" ). Other programs will use it only if it is already
running (see bug #127744 ). I'm not sure why you are getting freezes
though... I thought that you usually received an error messages if the
sound card was already in use...

It is probably worth indicating which desktop you are running (GNOME?
KDE?), which programs you see this with (what are you running in
addition to rhythmbox?) and attach the output of lspci -v to this bug.
Comment 3 John (J5) Palmieri 2004-12-21 11:20:14 EST
This is expected behavior for sound cards that do not have hardware
mixing.  All programs are being pushed to use Alsa by default and we
are actively working on a software mixing solution.  The solution for
now is to set the programs you use to use ESD as Sitsofe has pointed
out.  The situation should get better in FC4.  

Note You need to log in before you can comment on or make changes to this bug.