Bug 1434543 - [GSS](6.4.z) @GZIP usage causes java.util.zip.ZipException: Not in GZIP format
Summary: [GSS](6.4.z) @GZIP usage causes java.util.zip.ZipException: Not in GZIP format
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RESTEasy
Version: 6.4.14
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: CR1
: EAP 6.4.18
Assignee: Fedor Gavrilov
QA Contact: Peter Mackay
URL:
Whiteboard:
Depends On: 1372593
Blocks: 1496863 eap6418-payload 1492658
TreeView+ depends on / blocked
 
Reported: 2017-03-21 17:04 UTC by Carsten Lichy-Bittendorf
Modified: 2021-03-11 15:04 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 18:30:16 UTC
Type: Bug


Attachments (Terms of Use)
reproducer using arquillian (8.79 KB, application/zip)
2017-03-21 17:04 UTC, Carsten Lichy-Bittendorf
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBEAP-13427 0 Major Verified [GSS](7.0.z) Introduce property allowing GZIP interceptors to be enabled by default 2019-03-06 11:15:40 UTC
Red Hat Issue Tracker RESTEASY-1728 0 Major Closed Introduce property allowing GZIP interceptors to be enabled by default 2019-03-06 11:15:40 UTC
Red Hat Knowledge Base (Solution) 2981151 0 None None None 2017-04-27 15:16:19 UTC

Description Carsten Lichy-Bittendorf 2017-03-21 17:04:56 UTC
Created attachment 1265181 [details]
reproducer using arquillian

Description of problem:
Since EAP 6.4.CP14 existing implementation fails

Version-Release number of selected component (if applicable):
RESTEasy 2.3.17 

How reproducible:
- use attached reproducer

Actual results:
- Test fails: java.util.zip.ZipException: Not in GZIP format

Expected results:
- Works as in previous versions

Additional info:

Comment 5 Fedor Gavrilov 2017-04-21 12:32:09 UTC
Created attachment 1273317 [details]
fixed reproducer

Comment 13 Peter Mackay 2017-06-15 11:14:24 UTC
Reopening, because I am still getting the ZipException with EAP 6.4.16.CP.CR1 and resteasy.allowGzip set to true.

Comment 26 Tomas Hofman 2017-10-09 09:34:04 UTC
Upstream issue: https://issues.jboss.org/browse/JBEAP-13427

Comment 27 Tomas Hofman 2017-10-09 18:20:07 UTC
PR: https://github.com/jbossas/redhat-resteasy/pull/18

Merged

Comment 32 Jiří Bílek 2017-10-24 15:27:49 UTC
Verified with EAP 6.4.18.CP.CR1

Comment 33 Petr Penicka 2017-12-06 18:30:16 UTC
Released on Nov 14 2017 as part of EAP 6.4.18.


Note You need to log in before you can comment on or make changes to this bug.