Bug 1434619 - systemd-vconsole-setup.service fails to start on F26 Alpha base cloud image
systemd-vconsole-setup.service fails to start on F26 Alpha base cloud image
Status: CLOSED DUPLICATE of bug 1272686
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F26FinalBlocker
  Show dependency treegraph
 
Reported: 2017-03-21 19:56 EDT by Mike Ruckman
Modified: 2017-05-25 04:34 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-24 20:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Ruckman 2017-03-21 19:56:15 EDT
Description of problem:
Booting the latest F26 Base image results in the aforementioned service failing to start.

Version-Release number of selected component (if applicable):
systemd-233-2.fc26.x86_64
image: https://kojipkgs.fedoraproject.org/compose/26/Fedora-26-20170316.0/compose/CloudImages/x86_64/images/Fedora-Cloud-Base-26_Alpha-1.1.x86_64.qcow2

How reproducible:
Always

Steps to Reproduce:
1. Download F26 Alpha RC1 base cloud image [0]
2. Boot the image in a cloud provider (in this instance, testcloud)
3. Run: 'systemctl --all --failed'

Actual results:
● systemd-vconsole-setup.service loaded failed failed Setup Virtual Console 

Expected results:
● systemd-vconsole-setup.service loaded active plugged Setup Virtual Console 

Additional info:
This issue doesn't seem to crop up on other images installed to bare metal.
Comment 1 Mike Ruckman 2017-03-22 10:51:22 EDT
With the latest RC1.2 [0], I see the same.

  UNIT                           LOAD   ACTIVE SUB    DESCRIPTION 
-------------------------------------------------------------------                                      
● dnf-makecache.service          loaded failed failed dnf makecache                                     
● systemd-vconsole-setup.service loaded failed failed Setup Virtual Console  

[0] https://kojipkgs.fedoraproject.org/compose/26/Fedora-26-20170321.1/compose/CloudImages/x86_64/images/Fedora-Cloud-Base-26_Alpha-1.2.x86_64.qcow2
Comment 2 Fedora Blocker Bugs Application 2017-03-22 11:06:34 EDT
Proposed as a Blocker for 26-final by Fedora user roshi using the blocker tracking app because:

 Final System Services criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."
Comment 3 Dusty Mabe 2017-03-22 11:26:58 EDT
A few more notes:

We have had this problem in the past and it didn't get much attention.

https://bugzilla.redhat.com/show_bug.cgi?id=1272686

I guess the difference now is that plymouth is no longer masking the failure and we are seeing it when we run `systemctl --failed`.



Here is some journal output from the service during boot:

Mar 22 15:18:21 localhost systemd[1]: Starting Setup Virtual Console...
Mar 22 15:18:21 localhost systemd-vconsole-setup[591]: KD_FONT_OP_GET failed while trying to get the font metadata: Invalid argument
Mar 22 15:18:21 localhost systemd-vconsole-setup[591]: Fonts will not be copied to remaining consoles
Mar 22 15:18:21 localhost systemd[1]: Started Setup Virtual Console.
Mar 22 15:18:22 localhost.localdomain systemd-vconsole-setup[626]: /usr/bin/setfont failed with error code 1.
Mar 22 15:18:22 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
Mar 22 15:18:22 localhost.localdomain systemd[1]: Failed to start Setup Virtual Console.
Mar 22 15:18:22 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Unit entered failed state.
Mar 22 15:18:22 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.
Comment 4 Dusty Mabe 2017-03-22 11:39:19 EDT
ok that journal output was from a fedora atomic host.. The journal output from a fedora cloud base image is just a little different:

```
[root@cloudhost ~]# journalctl -u systemd-vconsole-setup 
-- Logs begin at Wed 2017-03-22 15:33:22 UTC, end at Wed 2017-03-22 15:38:28 UTC. --
Mar 22 15:33:23 localhost systemd[1]: Starting Setup Virtual Console...
Mar 22 15:33:23 localhost systemd[1]: Started Setup Virtual Console.
Mar 22 15:33:24 localhost.localdomain systemd-vconsole-setup[319]: setfont: putfont: 512,8x16:  failed: -1
Mar 22 15:33:24 localhost.localdomain systemd-vconsole-setup[319]: putfont: PIO_FONT: Invalid argument
Mar 22 15:33:24 localhost.localdomain systemd-vconsole-setup[319]: /usr/bin/setfont failed with error code 71.
Mar 22 15:33:24 localhost.localdomain systemd-vconsole-setup[319]: Setting source virtual console failed, ignoring remaining ones
Mar 22 15:33:24 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
Mar 22 15:33:24 localhost.localdomain systemd[1]: Failed to start Setup Virtual Console.
Mar 22 15:33:24 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Unit entered failed state.
Mar 22 15:33:24 localhost.localdomain systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.

```
Comment 5 Geoffrey Marr 2017-03-27 13:17:20 EDT
Discussed during the 2017-03-27 blocker review meeting: [1]

The decision was made to classify this bug as an AcceptedBlocker was made as it violates the following Final criteria:

"All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-03-27/f26-blocker-review.2017-03-27-16.01.txt
Comment 6 Dusty Mabe 2017-04-01 10:01:21 EDT
can we get someone from systemd to take a look at this one?
Comment 7 Zbigniew Jędrzejewski-Szmek 2017-05-24 20:53:51 EDT

*** This bug has been marked as a duplicate of bug 1272686 ***
Comment 8 Jan Kurik 2017-05-25 04:34:41 EDT
This bug has not been accepted on the Prioritized list as it is already on the list of Accepted Blockers.

Note You need to log in before you can comment on or make changes to this bug.