Bug 143464 - ghex-devel requires %{epoch} for ghex
Summary: ghex-devel requires %{epoch} for ghex
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ghex   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marius L. Jøhndal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-21 07:30 UTC by Seth Vidal
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 13:26:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2004-12-21 07:30:22 UTC
Description of problem:
Epoch:0 was removed from ghex spec file.
ghex was rebuilt.
ghex-devel requires %{epoch} in the spec file - but since epoch wasn't there it
requires LITERALLY %{epoch}, which always fails on lookup.

Needs to be fixed with 0 in place of %{epoch}

Comment 1 Michael Schwendt 2004-12-21 12:29:20 UTC
Fixed in CVS.

I'm to blame. In packages I had testbuilt and prepared in CVS, I
didn't want to touch epochs because I wanted to leave that decision to
the packager owners. ghex is one package where I picked up Matthias' 
euphoria for deleting epochs, and promptly ran into the trap.

Seth, could you ran a "rpm -qpR * | grep epoch" or something like that
in full pre-extras tree? Hopefully there are no other cases found.

Comment 2 Seth Vidal 2004-12-21 13:26:35 UTC
Michael,
 I ran it last night after I saw ghex-devel. There are no others.

Thanks. I'll build this and close.



Note You need to log in before you can comment on or make changes to this bug.