Bug 1434688 - RHOS 11 fails to deploy sriov
Summary: RHOS 11 fails to deploy sriov
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Saravanan KR
QA Contact: Maxim Babushkin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 07:50 UTC by Maxim Babushkin
Modified: 2017-05-17 20:10 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.7.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 20:10:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 448600 None None None 2017-03-23 19:20:41 UTC
OpenStack gerrit 451168 None None None 2017-03-29 12:58:27 UTC
Launchpad 1675036 None None None 2017-03-22 14:15:08 UTC

Description Maxim Babushkin 2017-03-22 07:50:37 UTC
Description of problem:
RHOS 11 unable to deploy SR-IOV.
Get syntax error by using templates from RHOS 10.

Version-Release number of selected component (if applicable):
RHOS 11
2017-03-08.3 puddle

How reproducible:
Deploy RHOS 11 Undercloud
Deploy Overcloud with SR-IOV function

Actual results:
The Overcloud deployment fails with the following error:

Error: Evaluation Error: Error while evaluating a Function Call, 
Syntax error: [{"devname"=>"p5p1", "physical_network"=>"sriov"}] is not a String at 
/etc/puppet/modules/nova/manifests/compute.pp:233:29 on node compute-0.localdomain

Expected results:
The deployment should pass

Comment 1 Saravanan KR 2017-03-22 09:56:58 UTC
As per the initial analysis, with the change [1], the format of the nova::compute::pci_passthrough value is changed from string to JSON. But as per the puppet-nova implementation, the parameter is expected as JSON encoded string. Will provided more details after validating the fix. 


[1] https://github.com/openstack/tripleo-heat-templates/commit/787685101179f13f6074901070cf307bd9bb0731#diff-99a22d37b829681d157f41d35c38e4c5L100

Comment 2 Saravanan KR 2017-03-23 09:12:02 UTC
Proposed patch upstream - https://review.openstack.org/#/c/448600/

Comment 4 Nir Yechiel 2017-03-23 19:20:41 UTC
Fix is under review on master: https://review.openstack.org/448600

We will need it backported to stable/ocata

Comment 6 Yariv 2017-03-29 12:48:50 UTC
Saravanan

Please move to Post i see launchpad is merged.
https://review.openstack.org/#/c/448600/

Thanks

Comment 7 Nir Yechiel 2017-03-29 12:57:41 UTC
(In reply to Yariv from comment #6)
> Saravanan
> 
> Please move to Post i see launchpad is merged.
> https://review.openstack.org/#/c/448600/
> 
> Thanks

Need to backport to stable/ocata for RHOSP 11.

Comment 8 Saravanan KR 2017-03-30 05:24:16 UTC
Downport URL - https://code.engineering.redhat.com/gerrit/#/c/101910/
I will wait for CI and push it.

Comment 10 Eran Kuris 2017-04-04 14:08:18 UTC
Verified on OSP-11 

[stack@puma07 ~]$ rpm -qa |grep openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-6.0.0-0.9.el7ost.noarch


Setup SRIOV 1 Compute  1 controller

Comment 11 errata-xmlrpc 2017-05-17 20:10:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.