Bug 1434692 - [OSP11] Downstream-only - Pacemaker remote is set to OS::Heat::None by default
Summary: [OSP11] Downstream-only - Pacemaker remote is set to OS::Heat::None by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: All
OS: All
urgent
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 08:00 UTC by Michele Baldessari
Modified: 2017-05-17 20:10 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:10:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Michele Baldessari 2017-03-22 08:00:13 UTC
Description of problem:
When fixing BZ#1406869 where we made the HA deployment the default in OSP, we did not include the pacemakerremote profile (likely it was fixed upstream later on).
So when we deploy certain ha services via pacemaker remote we will fail because there are no pacemaker_remote profiles listed in heat.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.20170307170102.3134785.0rc2.el7ost.noarch

How reproducible:
100% just deploy an ha service on a role with the PacemakerRemote profile

Comment 2 Udi Shkalim 2017-03-30 17:49:58 UTC
Verified on: openstack-tripleo-heat-templates-6.0.0-0.6.el7ost

Deployment with pacemaker remote passed:

[root@overcloud-galera-2 ~]# pcs status
Cluster name: tripleo_cluster
Stack: corosync
Current DC: controller-0 (version 1.1.15-11.el7_3.4-e174ec8) - partition with quorum
Last updated: Thu Mar 30 17:49:27 2017		Last change: Thu Mar 30 17:00:09 2017 by root via cibadmin on controller-0

9 nodes and 46 resources configured

Online: [ controller-0 controller-1 controller-2 overcloud-galera-0 overcloud-galera-1 overcloud-galera-2 ]
RemoteOnline: [ overcloud-rabbit-0 overcloud-rabbit-1 overcloud-rabbit-2 ]

Full list of resources:

 overcloud-rabbit-0	(ocf::pacemaker:remote):	Started controller-0
 overcloud-rabbit-1	(ocf::pacemaker:remote):	Started controller-1
 overcloud-rabbit-2	(ocf::pacemaker:remote):	Started controller-2
 Master/Slave Set: redis-master [redis]
     Masters: [ controller-0 ]
     Slaves: [ controller-1 controller-2 ]
     Stopped: [ overcloud-galera-0 overcloud-galera-1 overcloud-galera-2 overcloud-rabbit-0 overcloud-rabbit-1 overcloud-rabbit-2 ]
 Clone Set: rabbitmq-clone [rabbitmq]
     Started: [ overcloud-rabbit-0 overcloud-rabbit-1 overcloud-rabbit-2 ]
     Stopped: [ controller-0 controller-1 controller-2 overcloud-galera-0 overcloud-galera-1 overcloud-galera-2 ]
 Master/Slave Set: galera-master [galera]
     Masters: [ overcloud-galera-0 overcloud-galera-1 overcloud-galera-2 ]
     Stopped: [ controller-0 controller-1 controller-2 overcloud-rabbit-0 overcloud-rabbit-1 overcloud-rabbit-2 ]
 ip-192.168.24.10	(ocf::heartbeat:IPaddr2):	Started controller-0
 ip-10.0.0.106	(ocf::heartbeat:IPaddr2):	Started controller-1
 ip-172.17.1.17	(ocf::heartbeat:IPaddr2):	Started controller-2
 ip-172.17.1.10	(ocf::heartbeat:IPaddr2):	Started controller-0
 ip-172.17.3.18	(ocf::heartbeat:IPaddr2):	Started controller-1
 ip-172.17.4.12	(ocf::heartbeat:IPaddr2):	Started controller-2
 Clone Set: haproxy-clone [haproxy]
     Started: [ controller-0 controller-1 controller-2 ]
     Stopped: [ overcloud-galera-0 overcloud-galera-1 overcloud-galera-2 overcloud-rabbit-0 overcloud-rabbit-1 overcloud-rabbit-2 ]
 openstack-cinder-volume	(systemd:openstack-cinder-volume):	Started controller-0

Daemon Status:
  corosync: active/enabled
  pacemaker: active/enabled
  pcsd: active/enabled

Comment 3 errata-xmlrpc 2017-05-17 20:10:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.