Bug 143470 - About a warning message that nroff(1) outputs
About a warning message that nroff(1) outputs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: groff (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 05:25 EST by L3support
Modified: 2013-07-02 19:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 11:28:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-21 05:25:26 EST
Description of problem:
If man(1) displays a manual file encoded with legacy encodings (such
as EUC-JP), nroff(1) outputs the following warning message. 
--------
XXX
XXX WARNING: old character encoding and/or character set
XXX
--------
This message is at risk of causing end users an unexpected
misunderstanding. So could you prevent nroff(1) from outputting the
warning message?


Version-Release number of selected component (if applicable):
groff-1.18.1.1-3

How reproducible:
always

Steps to Reproduce:

Assume that the current locale ja_JP.UTF-8 
1. back up an original manual file
   # cd /usr/share/man/ja/man1
   # cp -p mv.1.gz mv.1.gz.utf8

2. convert UTF-8 to EUC-JP
   # gunzip mv.1.gz
   # iconv -f utf8 -t eucjp mv.1 > mv.1.eucjp
   # gzip -c mv.1.eucjp > mv.1.gz

3. display the manual file
   # man mv
  
Actual results:

  # man mv
  XXX
  XXX WARNING: old character encoding and/or character set
  XXX
  MV(1)
   :
   :

Expected results:

  # man mv
  MV(1)
   :
   :

Additional info:
Comment 1 RHEL4-L3support 2005-01-18 21:11:28 EST
Add RHEL4-L3support team in Japan
Comment 2 Jay Turner 2005-01-19 05:10:49 EST
Fujitsu, I'm not sure that I follow what you're asking for here.  Removing the
warning message isn't really a good idea, as then there's no indication that
character display problems might be rooted in the fact that the
encoding/character set is old.  What other solutions would Fujitsu like to see?
Comment 7 JoAnne K. Halligan 2005-01-24 11:28:32 EST
This is really a feature request rather than a bug.  
While it may be desirable for nroff to only report the error if it's asked for,
(such as with a verbose or other similar type of option), this is not actually
broken. These encoding warnings have also been the same for the last several
releases. Displaying these messages does not cause any harm as all the message
is saying is that the encoding is old and therefore display problems could
result.  Also, the encodings on a man page had to be converted in order to
trigger this, so it is not something that users will see in normal day-to-day
activity.  

The encodings in the latest release should be cleaned up. If there is something
that is not, the bugs should be opened specifically against the packages in
question rather than the package that is merely merely reporting the old encodings. 

This bug report is being closed as 'not a bug'. If the requester needs the
functionality changed, please open a new IT Feature Request using the template
with the required information.

Note You need to log in before you can comment on or make changes to this bug.