Bug 1434721 - CVE-2017-2641 CVE-2017-2643 CVE-2017-2644 CVE-2017-2645 moodle: Multiple security vulnerabilities [epel-7]
Summary: CVE-2017-2641 CVE-2017-2643 CVE-2017-2644 CVE-2017-2645 moodle: Multiple secu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: moodle
Version: epel7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: CVE-2017-2641, CVE-2017-2643, CVE-2017-2644, CVE-2017-2645
TreeView+ depends on / blocked
 
Reported: 2017-03-22 08:44 UTC by Andrej Nemec
Modified: 2017-04-07 13:49 UTC (History)
2 users (show)

Fixed In Version: moodle-2.7.19-1.el6 moodle-3.1.5-1.el7
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-30 21:19:08 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-03-22 08:44:13 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of epel-7.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When submitting as an update, use the fedpkg template provided in the next
comment(s).  This will include the bug IDs of this tracking bug as well as
the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
fedpkg commit message.

Comment 1 Andrej Nemec 2017-03-22 08:44:16 UTC
Use the following template to for the 'fedpkg update' request to submit an
update for this issue as it contains the top-level parent bug(s) as well as
this tracking bug.  This will ensure that all associated bugs get updated
when new packages are pushed to stable.

=====

# bugfix, security, enhancement, newpackage (required)
type=security

# testing, stable
request=testing

# Bug numbers: 1234,9876
bugs=1434718

# Description of your update
notes=Security fix for [PUT CVEs HERE]

# Enable request automation based on the stable/unstable karma thresholds
autokarma=True
stable_karma=3
unstable_karma=-3

# Automatically close bugs when this marked as stable
close_bugs=True

# Suggest that users restart after update
suggest_reboot=False

======

Additionally, you may opt to use the bodhi web interface to submit updates:

https://bodhi.fedoraproject.org/updates/new

Comment 2 Fedora Update System 2017-03-22 14:18:33 UTC
moodle-2.7.19-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-75190374ce

Comment 3 Fedora Update System 2017-03-22 14:27:35 UTC
moodle-3.1.5-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5794ee2486

Comment 4 Fedora Update System 2017-03-23 18:48:52 UTC
moodle-3.1.5-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5794ee2486

Comment 5 Fedora Update System 2017-03-30 21:19:08 UTC
moodle-2.7.19-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Aldo Necci 2017-04-03 13:46:51 UTC
moodle-2.7.19-1.el6 has been pushed to the Fedora EPEL 6 stable repository, but moodle 2.7.19 requires PHP 5.4.4 and Mysql 5.5.31 as shown here:
 https://docs.moodle.org/dev/Moodle_2.7_release_notes#Server_requirements

CentOS 6 (or EL 6 in general) has php-5.3.3 and mysql-5.1.73 and it's impossible to use moodle-2.7.19-1.el6 from EPEL 6.

At the end of normal istallation it's shows a blank page on browser instead to show the first steps of configuration.

The cron job of moodle (admin/cli/cron.php) returns this message:
Moodle 2.7 or later requires at least PHP 5.4.4 (currently using version 5.3.3)

Comment 7 Fedora Update System 2017-04-07 13:49:11 UTC
moodle-3.1.5-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.