Bug 1434732 - Automatic fencing configuration should NOT force a fence agent action
Summary: Automatic fencing configuration should NOT force a fence agent action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Asaf Hirshberg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 09:21 UTC by Chris Jones
Modified: 2017-05-17 20:11 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-6.0.0-4.el7ost python-tripleoclient-6.1.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:11:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 446184 None None None 2017-03-29 12:45:43 UTC
OpenStack gerrit 450251 None None None 2017-03-29 12:44:21 UTC
Launchpad 1670687 None None None 2017-03-22 09:21:28 UTC

Description Chris Jones 2017-03-22 09:21:28 UTC
Description of problem:

The automatic fencing feature forces the fencing agents to be configured with a specific action.

As per the recent investigations into Instance HA issues, this turns out to be a very bad choice and the action parameter should be optional.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Chris Jones 2017-03-22 09:23:09 UTC
Upstream patch is https://review.openstack.org/#/c/442497/ (master, ocata backport will be done after that lands).

Note: TripleO upstream CI has been experiencing a lot of issues in the last couple of weeks, which is holding up landing the fix for this bug.

Comment 2 Red Hat Bugzilla Rules Engine 2017-03-22 09:23:14 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Chris Jones 2017-03-29 14:52:36 UTC
The fix for this touches python-tripleoclient and tripleo-common. The patches for both have merged in master. The python-tripleoclient patch has also merged to stable/ocata. The tripleo-common has not yet merged to stable/ocata, but should do very shortly.

Comment 7 Asaf Hirshberg 2017-04-03 12:13:12 UTC
[stack@puma33 ~]$ openstack overcloud generate fencing instackenv.json
parameter_defaults:
  EnableFencing: true
  FencingConfig:
    devices:
    - agent: fence_ipmilan
      host_mac: 44:1e:a1:73:39:91
      params:
        ipaddr: 10.35.160.18
        login: admin
        passwd: admin
        pcmk_host_list: puma04
    - agent: fence_ipmilan
      host_mac: 44:1e:a1:73:3d:43
      params:
        ipaddr: 10.35.160.20
        login: admin
        passwd: admin
        pcmk_host_list: puma05
    - agent: fence_ipmilan
      host_mac: 44:1e:a1:73:36:6b
      params:
        ipaddr: 10.35.160.78
        login: admin
        passwd: admin
        pcmk_host_list: puma34
    - agent: fence_ipmilan
      host_mac: 44:1e:a1:73:38:5f
      params:
        ipaddr: 10.35.160.90
        login: admin
        passwd: admin
        pcmk_host_list: puma40

[stack@puma33 ~]$ rpm -qa |grep openstack-tripleo-common; rpm -qa |grep  python-tripleoclient
openstack-tripleo-common-6.0.0-4.el7ost.noarch
python-tripleoclient-6.1.0-3.el7ost.noarch
[stack@puma33 ~]$

Comment 8 errata-xmlrpc 2017-05-17 20:11:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.