Bug 1434781 - Update brick_dirs of volume section to have absolute brick path from all the hosts
Summary: Update brick_dirs of volume section to have absolute brick path from all the ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.10.7-0.0.15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ovirt-4.1.1-1
: 0.10.7-0.0.15
Assignee: Devyani Kota
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-03-22 11:22 UTC by SATHEESARAN
Modified: 2017-04-21 09:44 UTC (History)
5 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.15.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:44:44 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1?
rule-engine: blocker+
seamurph: planning_ack?
rbarry: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 74495 master MERGED gdeploy: add hostnames to brick_dir in volume config 2017-03-30 12:05:09 UTC
oVirt gerrit 74884 ovirt-4.1 MERGED gdeploy: add hostnames to brick_dir in volume config 2017-03-30 12:05:27 UTC

Description SATHEESARAN 2017-03-22 11:22:52 UTC
Description of problem:
-----------------------
gdeploy does the sorting of the hostnames because of which the arbiter host can't be determined by the order of listing under [hosts] section.

Gdeploy will fix the issue with this bug - https://bugzilla.redhat.com/show_bug.cgi?id=1434774

Till then volume section for arbiter volume should have the 'brick_dirs' having the absolute brick path from all the three hosts

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
ovirt-cockpit-plugin-0.10.7-0.0.15

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Populate the hosts in the descending order ( just to reproduce the issue ), listed either by IP or hostname

Actual results:
---------------
Arbiter brick is created on the first host, as gdeploy sorts the host by ascending order

Expected results:
------------------
generated gdeploy conf file to have the brick_dirs pointing to full brick path from all the hosts

Comment 2 SATHEESARAN 2017-04-03 17:09:35 UTC
Tested with cockpit-ovirt-dashboard-0.10.7-0.0.16.el7

brick_dirs option has got the absolute brick path name ( along with the hostname )


Note You need to log in before you can comment on or make changes to this bug.