Bug 1434785 - Include the tag query feature of hawkular-alerts
Summary: Include the tag query feature of hawkular-alerts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.z
Assignee: Matt Wringe
QA Contact: Liming Zhou
URL:
Whiteboard:
Depends On: 1427616
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 11:36 UTC by Mooli Tayer
Modified: 2017-05-18 09:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1427616
Environment:
Last Closed: 2017-05-18 09:27:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1235 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.1 bug fix update 2017-05-18 13:15:52 UTC

Description Mooli Tayer 2017-03-22 11:36:25 UTC
+++ This bug was initially created as a clone of Bug #1427616 +++

Description of problem:
Introduced in:
https://issues.jboss.org/browse/HWKALERTS-214

Version-Release number of selected component (if applicable):

# oc version
oc v1.4.0-alpha.1+5f9a5ec-217
kubernetes v1.4.0+776c994
features: Basic-Auth GSSAPI Kerberos SPNEGO

# curl -k -s     -H "Hawkular-Tenant: $HAWKULAR_TENANT"     -H "Authorization: Bearer $HAWKULAR_TOKEN"      "https://$HAWKULAR_HOST/hawkular/alerts/status"

{"currentNode":"hawkular-metrics-90tfy","distributed":"true","Implementation-Version":"0.23.6.Final","Built-From-Git-SHA1":"af57ffa0e3557ce5f50ef825d35322a0238c0f44","status":"STARTED","members":"hawkular-metrics-90tfy"}


How reproducible:
100%

events?tags=type queries work but a event?tagQuery is ignored.

BTW IT would be nice if hawkular would alert on query param it does not know but that is beside the point

--- Additional comment from Matt Wringe on 2017-02-28 13:47:46 EST ---

https://issues.jboss.org/browse/HWKALERTS-214 is not in any released Hawkular Alerts version. Once Alerts is released, Hawkular Metrics will be updated to include this new version.

Once availabe, origin metrics will be updated to include the newer version of Hawkular Metrics which will include this alerts feature.

Comment 1 Mooli Tayer 2017-03-22 11:46:20 UTC
This feature is critical for the cm-ops effort. We relay on tags to figure out what are the alerts a specific ManageIQ already saw. With out this feature each poll we will get all alerts. We know to ignore those but we will overload network usage and have severe performance consequences.

Comment 9 Troy Dawson 2017-04-28 15:55:34 UTC
This fix for this is in image
openshift3/metrics-hawkular-metrics:3.5.0-15

Comment 18 Lucas Ponce 2017-05-03 10:16:38 UTC
Perhaps you can reuse some curl-based scripts to create a simple trigger, push some metric and generate alerts.
Then those alerts can be queried with the tagQuery feature which is discussed in the bugzilla.

The JIRA https://issues.jboss.org/browse/HWKALERTS-210 is not related to this case but it has some scripting to help writting tests.

They can be modified to have tags and check the tagQuery feature.

Comment 26 errata-xmlrpc 2017-05-18 09:27:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1235


Note You need to log in before you can comment on or make changes to this bug.