Bug 1434828 - hosts config should be configured when using OpenDaylight
Summary: hosts config should be configured when using OpenDaylight
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 12:45 UTC by Itzik Brown
Modified: 2018-10-18 07:23 UTC (History)
7 users (show)

Fixed In Version: puppet-neutron-10.3.0-2.el7ost openstack-tripleo-heat-templates-6.0.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-05-17 20:11:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 448827 None None None 2017-03-23 00:03:27 UTC
OpenStack gerrit 452715 None None None 2017-04-05 12:57:49 UTC
Launchpad 1675211 None None None 2017-03-23 00:01:52 UTC

Description Itzik Brown 2017-03-22 12:45:27 UTC
Description of problem:
Host config parameters should be configured in the OVSDB of every overcloud node.
Neutron uses host specific information while doing port-binding.
When using OpenDaylight is configuration is not set so Instances fail to start.


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.20170307170102.3134785.0rc2.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.Using opendaylight launch an instance and verify it fails to start.
2.In Neutron log verify you see the message 'ODL hostconfigs REST/GET failed, will retry on next poll'
3.

Actual results:


Expected results:


Additional info:

Comment 7 Itzik Brown 2017-04-18 11:35:53 UTC
Able to start Instances.

Checked that ml2_odl section in /etc/neutron/plugins/ml2/ml2_conf.ini has:
port_binding_controller=network-topology

Checked with:
puppet-neutron-10.3.0-2.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-5.el7ost.noarch

Comment 8 errata-xmlrpc 2017-05-17 20:11:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.