Bug 1434841 - internal error: 'ssh' protocol is not yet supported
Summary: internal error: 'ssh' protocol is not yet supported
Keywords:
Status: CLOSED DUPLICATE of bug 1140166
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2017-03-22 13:05 UTC by Richard W.M. Jones
Modified: 2017-03-23 07:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 07:02:49 UTC


Attachments (Terms of Use)
log (8.95 KB, text/plain)
2017-03-22 13:05 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2017-03-22 13:05:32 UTC
Created attachment 1265399 [details]
log

Description of problem:

I'm sure I've seen this bug before, but I cannot find it now ...

$ guestfish --format=raw -a ssh://192.168.0.87/disk.img run
[...]
Original error from libvirt: internal error: 'ssh' protocol is not yet supported [code=1 int1=-1]

In this case 192.168.0.87 is an ssh server which is reachable
using ssh-agent (as is required by the ssh driver in qemu).

It appears this error comes from:

src/qemu/qemu_command.c:qemuBuildNetworkDriveStr

        case VIR_STORAGE_NET_PROTOCOL_SSH:
            virReportError(VIR_ERR_INTERNAL_ERROR, "%s",
                           _("'ssh' protocol is not yet supported"));
            goto cleanup;

Version-Release number of selected component (if applicable):

libvirt-daemon-3.1.0-1.fc27.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Run the guestfish command as above.

Additional info:

Further information about the libvirt XML etc can be found in the
attached log file.

Comment 1 Peter Krempa 2017-03-23 07:02:49 UTC

*** This bug has been marked as a duplicate of bug 1140166 ***


Note You need to log in before you can comment on or make changes to this bug.