Bug 1434843 - OSP10 -> OSP11 upgrade fails neutron-db-manage upgrade heads: oslo_db.exception.DBError: (pymysql.err.InternalError) (1054, u"Unknown column 'upstream.tenant_id' in 'field list'") [SQL: 'UPDATE bsn_routerrules bsn INNER JOIN routers upstream ON bsn.router
Summary: OSP10 -> OSP11 upgrade fails neutron-db-manage upgrade heads: oslo_db.excepti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-bigswitch
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: mathieu bultel
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1425432 1428976 (view as bug list)
Depends On:
Blocks: 1428976
TreeView+ depends on / blocked
 
Reported: 2017-03-22 13:12 UTC by Marius Cornea
Modified: 2017-05-17 20:11 UTC (History)
10 users (show)

Fixed In Version: python-networking-bigswitch-10.0.1-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:11:30 UTC


Attachments (Terms of Use)
bigswitch trace (5.12 KB, text/plain)
2017-03-22 13:12 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 448262 None None None 2017-03-22 16:45:00 UTC

Description Marius Cornea 2017-03-22 13:12:45 UTC
Created attachment 1265400 [details]
bigswitch trace

Description of problem:
OSP10 -> OSP11 upgrade fails neutron-db-manage upgrade heads: oslo_db.exception.DBError: (pymysql.err.InternalError) (1054, u"Unknown column 'upstream.tenant_id' in 'field list'") [SQL: 'UPDATE bsn_routerrules bsn INNER JOIN routers upstream ON bsn.router

Version-Release number of selected component (if applicable):
openstack-neutron-bigswitch-lldp-10.0.1-0.20170310222150.2a3fa5d.el7ost.noarch
openstack-neutron-bigswitch-agent-10.0.1-0.20170310222150.2a3fa5d.el7ost.noarch
python-networking-bigswitch-10.0.1-0.20170310222150.2a3fa5d.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upgrade OSP10 to OSP11

Actual results:
Upgrade fails during neutron-db-manage  upgrade heads.

Expected results:

Additional info:
Attaching full trace.

Comment 1 Brent Eagles 2017-03-22 16:45:01 UTC
I believe this was fixed by u/s patch:

https://review.openstack.org/#/c/448262/

Comment 4 Nir Yechiel 2017-03-23 19:39:37 UTC
*** Bug 1425432 has been marked as a duplicate of this bug. ***

Comment 5 Assaf Muller 2017-03-28 18:40:54 UTC
*** Bug 1428976 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2017-05-17 20:11:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.