Bug 1434860 - A series of x-Correlation-ID is created when tried to execute any subscription-manager command
Summary: A series of x-Correlation-ID is created when tried to execute any subscripti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
: 1440014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-22 13:40 UTC by Rehana
Modified: 2017-08-01 19:21 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.19.6-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:21:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1568 None None None 2017-03-23 18:25:19 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Rehana 2017-03-22 13:40:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):
subscription management server: 2.0.28-1
subscription management rules: 5.22
subscription-manager: 1.19.1-1.git.832.46d4712.el7
python-rhsm: 1.19.1-1.git.5753.46d4712.el7


How reproducible:
always

Steps to Reproduce:
1.Register client to candlepin server
2.look for correlation id in rhsm.log
3.also in the candlepin.log

Actual results:
Observed many Ids in the rhsm.log while the candlepin.log had only one of it

Expected results:
Should have only one id created.

Additional info:
rhsm.log
===========

2017-03-22 19:08:19,341 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: d5431c9f500f417eaf885978f3ac7402
2017-03-22 19:08:19,344 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: a57f81191cdd4e2bb84bb5944f86b361
2017-03-22 19:08:19,345 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 3f8d342a06a141de8b390b4b14872010
2017-03-22 19:08:19,349 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 9faf396190854f7b83401230915cb914
2017-03-22 19:08:19,352 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 9f295b34f1dd41bd8fc8f48a24f0bc43
2017-03-22 19:08:19,353 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 94414d04b1ec4269982717dcf931d59d
2017-03-22 19:08:19,355 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: e3d37efcfd914aa19a95138459455b08
2017-03-22 19:08:19,356 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 176b7cb9d9a84a33ae180aeaee2ab26e
2017-03-22 19:08:19,357 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 29d6828aa9f44722adbc50c407265da0
2017-03-22 19:08:19,359 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 93f5a5d17ce949faaa10f7dfa2d3e94a
2017-03-22 19:08:19,359 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 41bc8d7ab9804ce09ad47a4807e2f6cd
2017-03-22 19:08:19,361 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: b52eb63d8fb24732bc1d5bc23db200b9
2017-03-22 19:08:19,362 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 6d50bbb61a8341f8a8a4ce567ff79e1f
2017-03-22 19:08:19,363 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 279b03ee6aca4bfbaa54a413789f5e94
2017-03-22 19:08:19,365 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 13a82d1029874228a357eb9be9281895
2017-03-22 19:08:19,366 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 5cb3286c5d7347ab8d2da8935e74946d
2017-03-22 19:08:19,367 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 986eec2de20a458eb40b57c8b3c62810
2017-03-22 19:08:19,369 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: be03467819254d16a355734bbc954fac
2017-03-22 19:08:19,370 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 2708417f0d184fcebe256c12c7b66615
2017-03-22 19:08:19,371 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 4314f88900464e808daa1520d3d917e3
2017-03-22 19:08:19,373 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: b1587341319447e187d24cb776a1bfe3
2017-03-22 19:08:19,374 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: dd34c69750ef4d9680055a6fb4f3ffb8
2017-03-22 19:08:19,376 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: dfe122b4e7cb404bb709ab30295a29a7
2017-03-22 19:08:19,377 [INFO] subscription-manager:31655:MainThread @managercli.py:316 - X-Correlation-ID: 9de42bcac5584bd592eefc2e272113d1
2017-03-22 19:08:19,378 [INFO] subscription-manager:31655:MainThread @managercli.py:394 - Client Versions: {'python-rhsm': '1.19.1-1.git.5753.46d4712.el7', 'subscription-manager': '1.19.1-1.git.832.46d4712.el7'}
2017-03-22 19:08:19,379 [INFO] subscription-manager:31655:MainThread @connection.py:763 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-03-22 19:08:19,379 [INFO] subscription-manager:31655:MainThread @connection.py:763 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=none
2017-03-22 19:08:19,380 [INFO] subscription-manager:31655:MainThread @managercli.py:394 - Client Versions: {'python-rhsm': '1.19.1-1.git.5753.46d4712.el7', 'subscription-manager': '1.19.1-1.git.832.46d4712.el7'}
Registering to: F21-candlepin.usersys.redhat.com:8443/candlepin
2017-03-22 19:08:19,393 [INFO] subscription-manager:31655:MainThread @managercli.py:369 - Consumer Identity name=None uuid=None
2017-03-22 19:08:19,396 [INFO] subscription-manager:31655:MainThread @managercli.py:369 - Consumer Identity name=None uuid=None
2017-03-22 19:08:19,396 [INFO] subscription-manager:31655:MainThread @connection.py:763 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=basic username=admin
2017-03-22 19:08:19,836 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=0bdb2274-3994-4c66-83b3-36eb3e0efe6e, request="GET /candlepin/"
The system has been registered with ID: ff16d023-9a8c-4a19-8a98-ed9181dd2c66 
2017-03-22 19:08:20,635 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, request="POST /candlepin/consumers?owner=admin"
2017-03-22 19:08:20,637 [INFO] subscription-manager:31655:MainThread @managerlib.py:76 - Consumer created: {'consumer_name': u'dhcp35-53.lab.eng.blr.redhat.com', 'uuid': 'ff16d023-9a8c-4a19-8a98-ed9181dd2c66'}
2017-03-22 19:08:20,639 [INFO] subscription-manager:31655:MainThread @connection.py:763 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-03-22 19:08:20,652 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=ec0a68f8-f66e-4c72-a170-37d0d2c331f2, request="GET /candlepin/"
2017-03-22 19:08:20,669 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=b4229137-f843-42ea-99b2-0868f25f1c2f, request="GET /candlepin/status"
2017-03-22 19:08:20,670 [INFO] subscription-manager:31655:MainThread @managercli.py:405 - Server Versions: {'rules-version': u'5.22', 'candlepin': u'2.0.28-1', 'server-type': 'Red Hat Subscription Management'}
2017-03-22 19:08:20,682 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=5f585ef1-8cd4-45e9-a30d-07f98a278fea, request="GET /candlepin/"
2017-03-22 19:08:20,683 [INFO] subscription-manager:31655:MainThread @cache.py:401 - Server does not support packages, skipping profile upload.
2017-03-22 19:08:20,697 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=229d452a-26d9-4f7b-897b-37851b81c2fb, request="GET /candlepin/status"
2017-03-22 19:08:20,697 [INFO] subscription-manager:31655:MainThread @managercli.py:1227 - System registered, updating entitlements if needed
2017-03-22 19:08:20,800 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=e5842cc7-ada1-470c-8e8f-8b33305004bc, request="GET /candlepin/consumers/ff16d023-9a8c-4a19-8a98-ed9181dd2c66/certificates/serials"
2017-03-22 19:08:20,801 [INFO] subscription-manager:31655:MainThread @entcertlib.py:130 - certs updated:
Total updates: 0
Found (local) serial# []
Expected (UEP) serial# []
Added (new)
  <NONE>
Deleted (rogue):
  <NONE>
2017-03-22 19:08:20,895 [INFO] subscription-manager:31655:MainThread @connection.py:509 - Response: status=200, requestUuid=4d5fe5a2-0ec4-4540-bb27-c08f54987887, request="GET /candlepin/consumers/ff16d023-9a8c-4a19-8a98-ed9181dd2c66/compliance"
2017-03-22 19:08:20,897 [INFO] subscription-manager:31655:MainThread @cert_sorter.py:205 - Product status: valid_products= partial_products= expired_products= unentitled_producs=37060 future_products= valid_until=None
2017-03-22 19:08:20,952 [INFO] rhsmd:31644:MainThread @connection.py:763 - Connection built: host=F21-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-03-22 19:08:21,094 [INFO] rhsmd:31644:MainThread @connection.py:509 - Response: status=200, requestUuid=3cb3ac3e-18d6-4c97-ad6e-b2c72518c200, request="GET /candlepin/consumers/ff16d023-9a8c-4a19-8a98-ed9181dd2c66/compliance"
2017-03-22 19:08:21,098 [INFO] rhsmd:31644:MainThread @cert_sorter.py:205 - Product status: valid_products= partial_products= expired_products= unentitled_producs=37060 future_products= valid_until=None


candlepin.log
============
2017-03-22 19:08:19,829 [thread=http-bio-8443-exec-9] [req=0bdb2274-3994-4c66-83b3-36eb3e0efe6e, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-03-22 19:08:19,829 [thread=http-bio-8443-exec-9] [req=0bdb2274-3994-4c66-83b3-36eb3e0efe6e, org=, csid=d5431c9f500f417eaf885978f3ac7402] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-03-22 19:08:19,830 [thread=http-bio-8443-exec-9] [req=0bdb2274-3994-4c66-83b3-36eb3e0efe6e, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=1
2017-03-22 19:08:19,841 [thread=http-bio-8443-exec-10] [req=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=POST, uri=/candlepin/consumers?owner=admin
2017-03-22 19:08:19,901 [thread=http-bio-8443-exec-10] [req=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.resource.ConsumerResource - Sanitizing facts for consumer dhcp35-53.lab.eng.blr.redhat.com
2017-03-22 19:08:20,540 [thread=http-bio-8443-exec-10] [req=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.resource.ConsumerResource - Consumer ff16d023-9a8c-4a19-8a98-ed9181dd2c66 created in org admin
2017-03-22 19:08:20,615 [thread=http-bio-8443-exec-10] [req=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, org=, csid=d5431c9f500f417eaf885978f3ac7402] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-03-22 19:08:20,627 [thread=http-bio-8443-exec-10] [req=7ad1acc6-a23b-47fc-81f8-a8b4c4d4b37c, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=786
2017-03-22 19:08:20,644 [thread=http-bio-8443-exec-4] [req=ec0a68f8-f66e-4c72-a170-37d0d2c331f2, org=, csid=d5431c9f500f417eaf885978f3ac7402] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-03-22 19:08:20,645 [thread=http-bio-8443-exec-4] [req=ec0a68f8-f66e-4c72-a170-37d0d2c331f2, org=, csid=d5431c9f500f417eaf885978f3ac7402] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
<snip>

Comment 1 Kevin Howell 2017-04-10 15:18:23 UTC
*** Bug 1440014 has been marked as a duplicate of this bug. ***

Comment 3 Shwetha Kallesh 2017-04-17 07:32:34 UTC
Marking bug as verified as I see only one correlation Id in rhsm.log

[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.7-1.el7
python-rhsm: 1.19.4-1.el7


[root@dhcp35-160 ~]# subscription-manager register --force
The system with UUID a16a76f4-c7b1-4c27-8497-fcca7de6b510 has been unregistered
Registering to: Shwetha-candlepin.usersys.redhat.com:8443/candlepin
Username: testuser1
Password: 
Organization: admin
The system has been registered with ID: 33f1efe0-52af-472a-a601-c38b855b547a 


[root@dhcp35-160 ~]# tail -f /var/log/rhsm/rhsm.log
2017-04-17 12:56:43,518 [INFO] rhsmd:25254:MainThread @rhsmd:263 - rhsmd started
2017-04-17 12:56:43,609 [INFO] subscription-manager:25248:MainThread @managercli.py:507 - X-Correlation-ID: 04d511a31bcf4a33803380f3d219731f
2017-04-17 12:56:43,609 [INFO] subscription-manager:25248:MainThread @managercli.py:396 - Client Versions: {'python-rhsm': '1.19.4-1.el7', 'subscription-manager': '1.19.7-1.el7'}
2017-04-17 12:56:43,610 [INFO] subscription-manager:25248:MainThread @connection.py:774 - Connection built: host=Shwetha-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-04-17 12:56:43,611 [INFO] subscription-manager:25248:MainThread @connection.py:774 - Connection built: host=Shwetha-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=none
2017-04-17 12:56:43,612 [INFO] subscription-manager:25248:MainThread @managercli.py:396 - Client Versions: {'python-rhsm': '1.19.4-1.el7', 'subscription-manager': '1.19.7-1.el7'}
2017-04-17 12:56:43,623 [INFO] subscription-manager:25248:MainThread @managercli.py:371 - Consumer Identity name=dhcp35-160.lab.eng.blr.redhat.com uuid=a16a76f4-c7b1-4c27-8497-fcca7de6b510
2017-04-17 12:56:43,625 [INFO] subscription-manager:25248:MainThread @managercli.py:371 - Consumer Identity name=dhcp35-160.lab.eng.blr.redhat.com uuid=a16a76f4-c7b1-4c27-8497-fcca7de6b510
2017-04-17 12:56:43,838 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=204, requestUuid=2f118b94-b77c-4f26-a04c-0d4ba15f318d, request="DELETE /candlepin/consumers/a16a76f4-c7b1-4c27-8497-fcca7de6b510"
2017-04-17 12:56:43,838 [INFO] subscription-manager:25248:MainThread @managerlib.py:803 - Successfully un-registered.
2017-04-17 12:56:43,841 [INFO] subscription-manager:25248:MainThread @managerlib.py:891 - Cleaned local data
2017-04-17 12:56:43,841 [INFO] subscription-manager:25248:MainThread @managercli.py:1118 - --force specified, unregistered old consumer: a16a76f4-c7b1-4c27-8497-fcca7de6b510
2017-04-17 12:56:51,038 [INFO] subscription-manager:25248:MainThread @connection.py:774 - Connection built: host=Shwetha-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=basic username=testuser1
2017-04-17 12:56:51,197 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=52574d0c-87ab-4b5f-beb4-33f9eedacc12, request="GET /candlepin/users/testuser1/owners"
2017-04-17 12:56:53,863 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=925edad6-bc23-4820-b9a6-fc11ab5405ed, request="GET /candlepin/"
2017-04-17 12:56:54,426 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=d3344705-7765-4637-b922-68b9ca676404, request="POST /candlepin/consumers?owner=admin"
2017-04-17 12:56:54,428 [INFO] subscription-manager:25248:MainThread @managerlib.py:76 - Consumer created: {'consumer_name': u'dhcp35-160.lab.eng.blr.redhat.com', 'uuid': '33f1efe0-52af-472a-a601-c38b855b547a'}
2017-04-17 12:56:54,428 [INFO] subscription-manager:25248:MainThread @connection.py:774 - Connection built: host=Shwetha-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-04-17 12:56:54,439 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=96380251-343b-4b3f-a296-c593dd9a4b80, request="GET /candlepin/"
2017-04-17 12:56:54,457 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=8dcb23a6-1a5a-4331-9c8f-abeea66cd491, request="GET /candlepin/status"
2017-04-17 12:56:54,458 [INFO] subscription-manager:25248:MainThread @managercli.py:407 - Server Versions: {'rules-version': u'5.23', 'candlepin': u'2.1.0-1', 'server-type': 'Red Hat Subscription Management'}
2017-04-17 12:56:54,472 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=04bcc779-c242-4743-864a-a1a1df63a903, request="GET /candlepin/"
2017-04-17 12:56:54,473 [INFO] subscription-manager:25248:MainThread @cache.py:401 - Server does not support packages, skipping profile upload.
2017-04-17 12:56:54,487 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=6c7e7566-ba48-48fc-b2ca-25b0a5b977a7, request="GET /candlepin/status"
2017-04-17 12:56:54,487 [INFO] subscription-manager:25248:MainThread @managercli.py:1231 - System registered, updating entitlements if needed
2017-04-17 12:56:54,617 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=7cf7ae54-57ee-4eaf-a39f-b32c0d8d1c7b, request="GET /candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/certificates/serials"
2017-04-17 12:56:54,617 [INFO] subscription-manager:25248:MainThread @entcertlib.py:130 - certs updated:
Total updates: 0
Found (local) serial# []
Expected (UEP) serial# []
Added (new)
  <NONE>
Deleted (rogue):
  <NONE>
2017-04-17 12:56:54,719 [INFO] subscription-manager:25248:MainThread @connection.py:514 - Response: status=200, requestUuid=8f81dd00-e467-498d-89db-8a542d580e7d, request="GET /candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/compliance"
2017-04-17 12:56:54,720 [INFO] subscription-manager:25248:MainThread @cert_sorter.py:205 - Product status: valid_products= partial_products= expired_products= unentitled_producs=69 and 32060 future_products= valid_until=None
2017-04-17 12:56:54,770 [INFO] rhsmd:25254:MainThread @connection.py:774 - Connection built: host=Shwetha-candlepin.usersys.redhat.com port=8443 handler=/candlepin auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2017-04-17 12:56:54,866 [INFO] rhsmd:25254:MainThread @connection.py:514 - Response: status=200, requestUuid=dc497b00-7d72-43a6-8094-8adf508f7dab, request="GET /candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/compliance"
2017-04-17 12:56:54,868 [INFO] rhsmd:25254:MainThread @cert_sorter.py:205 - Product status: valid_products= partial_products= expired_products= unentitled_producs=69 and 32060 future_products= valid_until=None



candlepin.log

2017-04-17 12:56:43,674 [thread=http-nio-8443-exec-2] [req=2f118b94-b77c-4f26-a04c-0d4ba15f318d, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=DELETE, uri=/candlepin/consumers/a16a76f4-c7b1-4c27-8497-fcca7de6b510
2017-04-17 12:56:43,817 [thread=http-nio-8443-exec-2] [req=2f118b94-b77c-4f26-a04c-0d4ba15f318d, org=admin, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:43,828 [thread=http-nio-8443-exec-2] [req=2f118b94-b77c-4f26-a04c-0d4ba15f318d, org=admin, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=204, content-type="null", time=154
2017-04-17 12:56:51,168 [thread=http-nio-8443-exec-4] [req=52574d0c-87ab-4b5f-beb4-33f9eedacc12, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/users/testuser1/owners
2017-04-17 12:56:51,182 [thread=http-nio-8443-exec-4] [req=52574d0c-87ab-4b5f-beb4-33f9eedacc12, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:51,188 [thread=http-nio-8443-exec-4] [req=52574d0c-87ab-4b5f-beb4-33f9eedacc12, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=20
2017-04-17 12:56:53,851 [thread=http-nio-8443-exec-9] [req=925edad6-bc23-4820-b9a6-fc11ab5405ed, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-04-17 12:56:53,851 [thread=http-nio-8443-exec-9] [req=925edad6-bc23-4820-b9a6-fc11ab5405ed, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:53,854 [thread=http-nio-8443-exec-9] [req=925edad6-bc23-4820-b9a6-fc11ab5405ed, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=3
2017-04-17 12:56:53,865 [thread=http-nio-8443-exec-5] [req=d3344705-7765-4637-b922-68b9ca676404, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=POST, uri=/candlepin/consumers?owner=admin
2017-04-17 12:56:53,903 [thread=http-nio-8443-exec-5] [req=d3344705-7765-4637-b922-68b9ca676404, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.resource.ConsumerResource - Sanitizing facts for consumer dhcp35-160.lab.eng.blr.redhat.com
2017-04-17 12:56:54,389 [thread=http-nio-8443-exec-5] [req=d3344705-7765-4637-b922-68b9ca676404, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.resource.ConsumerResource - Consumer 33f1efe0-52af-472a-a601-c38b855b547a created in org admin
2017-04-17 12:56:54,403 [thread=http-nio-8443-exec-5] [req=d3344705-7765-4637-b922-68b9ca676404, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,415 [thread=http-nio-8443-exec-5] [req=d3344705-7765-4637-b922-68b9ca676404, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=550
2017-04-17 12:56:54,429 [thread=http-nio-8443-exec-12] [req=96380251-343b-4b3f-a296-c593dd9a4b80, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-04-17 12:56:54,429 [thread=http-nio-8443-exec-12] [req=96380251-343b-4b3f-a296-c593dd9a4b80, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,430 [thread=http-nio-8443-exec-12] [req=96380251-343b-4b3f-a296-c593dd9a4b80, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=1
2017-04-17 12:56:54,439 [thread=http-nio-8443-exec-2] [req=8dcb23a6-1a5a-4331-9c8f-abeea66cd491, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/status
2017-04-17 12:56:54,441 [thread=http-nio-8443-exec-2] [req=8dcb23a6-1a5a-4331-9c8f-abeea66cd491, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,448 [thread=http-nio-8443-exec-2] [req=8dcb23a6-1a5a-4331-9c8f-abeea66cd491, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=9
2017-04-17 12:56:54,462 [thread=http-nio-8443-exec-4] [req=04bcc779-c242-4743-864a-a1a1df63a903, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-04-17 12:56:54,462 [thread=http-nio-8443-exec-4] [req=04bcc779-c242-4743-864a-a1a1df63a903, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,463 [thread=http-nio-8443-exec-4] [req=04bcc779-c242-4743-864a-a1a1df63a903, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=1
2017-04-17 12:56:54,476 [thread=http-nio-8443-exec-9] [req=6c7e7566-ba48-48fc-b2ca-25b0a5b977a7, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/status
2017-04-17 12:56:54,477 [thread=http-nio-8443-exec-9] [req=6c7e7566-ba48-48fc-b2ca-25b0a5b977a7, org=, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,478 [thread=http-nio-8443-exec-9] [req=6c7e7566-ba48-48fc-b2ca-25b0a5b977a7, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=2
2017-04-17 12:56:54,493 [thread=http-nio-8443-exec-5] [req=7cf7ae54-57ee-4eaf-a39f-b32c0d8d1c7b, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/certificates/serials
2017-04-17 12:56:54,607 [thread=http-nio-8443-exec-5] [req=7cf7ae54-57ee-4eaf-a39f-b32c0d8d1c7b, org=admin, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,607 [thread=http-nio-8443-exec-5] [req=7cf7ae54-57ee-4eaf-a39f-b32c0d8d1c7b, org=admin, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=114
2017-04-17 12:56:54,620 [thread=http-nio-8443-exec-8] [req=8f81dd00-e467-498d-89db-8a542d580e7d, org=, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/compliance
2017-04-17 12:56:54,708 [thread=http-nio-8443-exec-8] [req=8f81dd00-e467-498d-89db-8a542d580e7d, org=admin, csid=04d511a31bcf4a33803380f3d219731f] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,710 [thread=http-nio-8443-exec-8] [req=8f81dd00-e467-498d-89db-8a542d580e7d, org=admin, csid=04d511a31bcf4a33803380f3d219731f] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=90
2017-04-17 12:56:54,774 [thread=http-nio-8443-exec-1] [req=dc497b00-7d72-43a6-8094-8adf508f7dab, org=, csid=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/consumers/33f1efe0-52af-472a-a601-c38b855b547a/compliance
2017-04-17 12:56:54,854 [thread=http-nio-8443-exec-1] [req=dc497b00-7d72-43a6-8094-8adf508f7dab, org=admin, csid=] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-04-17 12:56:54,857 [thread=http-nio-8443-exec-1] [req=dc497b00-7d72-43a6-8094-8adf508f7dab, org=admin, csid=] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=83
2017-04-17 12:58:00,049 [thread=QuartzScheduler_Worker-13] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.CertificateRevocationListTask
2017-04-17 12:58:00,049 [thread=QuartzScheduler_Worker-13] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.CertificateRevocationListTask - Executing CRL Job. CRL filePath=/var/lib/candlepin/candlepin-crl.crl
2017-04-17 12:58:00,100 [thread=QuartzScheduler_Worker-13] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=51
2017-04-17 13:00:00,049 [thread=QuartzScheduler_Worker-6] [job=ActiveEntitlementJob-42231e5c-8572-4602-b652-45c9148b02a8, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.ActiveEntitlementJob
2017-04-17 13:00:00,050 [thread=QuartzScheduler_Worker-6] [job=ActiveEntitlementJob-42231e5c-8572-4602-b652-45c9148b02a8, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=1
2017-04-17 13:00:00,073 [thread=QuartzScheduler_Worker-2] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.CertificateRevocationListTask
2017-04-17 13:00:00,074 [thread=QuartzScheduler_Worker-3] [job=SweepBarJob-1d734f1c-32eb-411a-9fcd-29483e567753, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.SweepBarJob
2017-04-17 13:00:00,074 [thread=QuartzScheduler_Worker-7] [job=ExpiredPoolsJob-ba8727a5-5a80-47c6-9e53-a732bfc35f0e, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Starting job: org.candlepin.pinsetter.tasks.ExpiredPoolsJob
2017-04-17 13:00:00,075 [thread=QuartzScheduler_Worker-2] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.CertificateRevocationListTask - Executing CRL Job. CRL filePath=/var/lib/candlepin/candlepin-crl.crl
2017-04-17 13:00:00,079 [thread=QuartzScheduler_Worker-3] [job=SweepBarJob-1d734f1c-32eb-411a-9fcd-29483e567753, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=5
2017-04-17 13:00:00,081 [thread=QuartzScheduler_Worker-2] [job=CertificateRevocationListTask-0d676ca5-4e3f-4e25-83b7-2e5fe4cf2423, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=8
2017-04-17 13:00:00,129 [thread=QuartzScheduler_Worker-7] [job=ExpiredPoolsJob-ba8727a5-5a80-47c6-9e53-a732bfc35f0e, org=, csid=] INFO  org.candlepin.pinsetter.tasks.KingpinJob - Job completed: time=55

Comment 4 errata-xmlrpc 2017-08-01 19:21:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.