Bug 143498 - nc not compiled with -DTELNET
nc not compiled with -DTELNET
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 13:15 EST by Todd J Martin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-23 03:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to nc.spec to build with -DTELNET (324 bytes, patch)
2004-12-21 13:22 EST, Todd J Martin
no flags Details | Diff

  None (edit)
Description Todd J Martin 2004-12-21 13:15:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9

Description of problem:
The man page for nc documents a -t option to allow communication with
a telnet daemon.  Currently, this option is not actually available
because  nc was not compiled with the necessary option.


Version-Release number of selected component (if applicable):
nc-1.10-22

How reproducible:
Always

Steps to Reproduce:
1. Run nc -h
2. Run nc -t localhost 23
3.
    

Actual Results:  Notice no -t option.

# nc -h
[v1.10]
connect to somewhere:   nc [-options] hostname port[s] [ports] ...
listen for inbound:     nc -l -p port [-options] [hostname] [port]
options:
        -g gateway              source-routing hop point[s], up to 8
        -G num                  source-routing pointer: 4, 8, 12, ...
        -h                      this cruft
        -i secs                 delay interval for lines sent, ports
scanned
        -l                      listen mode, for inbound connects
        -n                      numeric-only IP addresses, no DNS
        -o file                 hex dump of traffic
        -p port                 local port number
        -r                      randomize local and remote ports
        -s addr                 local source address
        -u                      UDP mode
        -v                      verbose [use twice to be more verbose]
        -w secs                 timeout for connects and final net reads
        -z                      zero-I/O mode [used for scanning]
port numbers can be individual or ranges: lo-hi [inclusive]



# nc -t localhost 23
nc -h for help


Expected Results:  One of the options should be for -t.

Using the -t option should work

Additional info:
Comment 1 Todd J Martin 2004-12-21 13:22:18 EST
Created attachment 108972 [details]
Patch to nc.spec to build with -DTELNET

This patch to the nc.spec file will build nc with the necessary option to
support telnet negotiation.
Comment 3 Radek Vokal 2004-12-23 03:08:17 EST
The support is added to nc-1.10-24.

Note You need to log in before you can comment on or make changes to this bug.