Bug 1435010 - GNOME fails to start without modesetting (Fedora 'basic graphics') mode
GNOME fails to start without modesetting (Fedora 'basic graphics') mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: AlphaBlocker/F26AlphaBlocker
  Show dependency treegraph
 
Reported: 2017-03-22 17:48 EDT by Adam Williamson
Modified: 2017-03-29 01:05 EDT (History)
12 users (show)

See Also:
Fixed In Version: gdm-3.24.0-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-29 01:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full journal contents (283.56 KB, text/plain)
2017-03-22 17:52 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2017-03-22 17:48:37 EDT
To reproduce, just try and boot the Alpha RC2 Workstation live image in 'basic graphics' mode (from the 'Troubleshooting' menu in the bootloader). Image link:

https://dl.fedoraproject.org/pub/alt/stage/26_Alpha-1.2/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-26_Alpha-1.2.iso

For me, on two setups (a bare metal laptop - Dell XPS 13 third gen - and a spice/qxl VM), boot ends up at GDM (when it should boot to the shell). If you try to log in as 'Live user', it dumps you right back to gdm.

What the 'basic graphics mode' boot option really does, these days, is just add 'nomodeset' to the kernel parameters, the idea being this will force the system back onto some kind of 'fallback' driver.

Looking at the logs, I see this:

Mar 22 21:38:14 localhost-live gnome-shell[1604]: Can't initialize KMS backend: could not find drm kms device
Mar 22 21:38:14 localhost-live gnome-session[1511]: gnome-session-binary[1511]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 22 21:38:14 localhost-live gnome-session-binary[1511]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Mar 22 21:38:14 localhost-live gnome-session-binary[1511]: Unrecoverable failure in required component org.gnome.Shell.desktop
Mar 22 21:38:14 localhost-live gdm-autologin][1328]: pam_unix(gdm-autologin:session): session closed for user liveuser

which looks a lot like the problem, but I'll attach the full log.

Proposing as an Alpha blocker, per criterion "Expected image boot behavior", which has a footnote:

"The boot menu for all supported installer and live images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer or desktop and attempting to use the generic driver."

https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#Expected_image_boot_behavior
Comment 1 Adam Williamson 2017-03-22 17:52 EDT
Created attachment 1265502 [details]
full journal contents
Comment 2 Adam Williamson 2017-03-22 17:52:57 EDT
This message seems to come from mutter, so maybe that's the right component...
Comment 3 Kevin Fenzi 2017-03-22 17:56:09 EDT
+1 blocker. 

I also see this on a macbook here.
Comment 4 Adam Williamson 2017-03-22 17:59:09 EDT
Comparing to F25, this same thing actually seems to happen on the *first* login attempt there; it also boots to GDM (instead of booting straight to the desktop), and similar messages are present in the journal. But if you then click 'Live System User' in gdm, it logs in fine, and the errors don't seem to be present for that session.
Comment 5 Mike Ruckman 2017-03-22 21:24:11 EDT
+1 as well for blocker.
Comment 6 Stephen Gallagher 2017-03-23 09:15:49 EDT
+1 to block. I've also seen it on a custom system I have at home with a too-new GeForce card.
Comment 7 Kalev Lember 2017-03-23 10:17:43 EDT
Adding some people to CC who might be able to help with this.
Comment 8 Adam Williamson 2017-03-23 17:09:38 EDT
Discussed at 2017-03-23 Fedora 26 Alpha Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2017-03-23/f26-alpha-go-no-go-meeting-2nd.2017-03-23-17.00.log.txt . Accepted as a blocker per the cited criterion footnote.
Comment 9 Kalev Lember 2017-03-24 08:26:12 EDT
Adding rtcm and jadahl who mclasen thought could help.
Comment 10 Adam Williamson 2017-03-24 15:57:25 EDT
Still happens with GNOME 3.24.0 and kernel rc3.git0.2 , FWIW.
Comment 11 Ray Strode [halfline] 2017-03-24 22:46:44 EDT
logs show gdm misbehaving, though I haven't quite figured out why yet. reassigning.
Comment 12 Ray Strode [halfline] 2017-03-24 23:39:22 EDT
i think I see the problem now, but I haven't tested a fix yet.

This commit, changes the way list of session dirs is computed from a static list to something dynamically generated:

https://git.gnome.org/browse/gdm/commit/?id=5b1e625417c274823c66a552f37d912986fc34d8

The problem is it caches the results too aggressively, so the wayland dirs don't get pruned when the ignore-wayland flag is set.

Easy fix is to just skip caching altogether, it's not really necessary.
Comment 13 Fedora Update System 2017-03-25 00:48:12 EDT
gdm-3.24.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ca9825d5a2
Comment 14 Adam Williamson 2017-03-25 02:32:52 EDT
Thanks a lot for figuring this out! I just threw together a live image including the gdm build, and it now acts like F25 (initially boots to GDM, but can log in by clicking Live System User). Will check that it works post-install too then fire an RC3 request. Thanks!
Comment 15 Fedora Update System 2017-03-25 20:40:00 EDT
gdm-3.24.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ca9825d5a2
Comment 16 Fedora Update System 2017-03-29 01:05:33 EDT
gdm-3.24.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.