Bug 1435100 - fcontext --extract does not work when socket entries are present in custom fcontext policy
Summary: fcontext --extract does not work when socket entries are present in custom fc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks: 1435127
TreeView+ depends on / blocked
 
Reported: 2017-03-23 07:16 UTC by Zdenek Pytela
Modified: 2017-08-01 16:16 UTC (History)
6 users (show)

Fixed In Version: policycoreutils-2.5-15.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1435127 (view as bug list)
Environment:
Last Closed: 2017-08-01 16:16:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1883 normal SHIPPED_LIVE policycoreutils bug fix update 2017-08-01 17:53:54 UTC
Red Hat Bugzilla 1435127 None CLOSED fcontext --extract does not work when socket entries are present in custom fcontext policy 2018-05-02 13:21:05 UTC
Red Hat Knowledge Base (Solution) 2981261 None None None 2017-03-25 16:05:19 UTC

Description Zdenek Pytela 2017-03-23 07:16:21 UTC
Description of problem:
semanage fcontext -E does not work when custom policy contains filetype socket spoecification.

Version-Release number of selected component (if applicable):
policycoreutils-python-2.5-11.el7_3.x86_64

How reproducible:
always

Steps to Reproduce:
1. semanage fcontext -E
2. semanage fcontext -a -f s -t httpd_var_run_t '/var/www/\.sockets(/.*)?'
3. semanage fcontext -E

Actual results:
KeyError: socket
(exit code 1)

Expected results:
list of customizable commands


Additional info:
Seems to be fixed in this commit:
https://github.com/SELinuxProject/selinux/commit/317743bbe2a235a5c68f1066b4153e0726a3118f

semanage fcontext with other file types work correctly
the same is valid for RHEL 7.4 and F25

Comment 8 errata-xmlrpc 2017-08-01 16:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1883


Note You need to log in before you can comment on or make changes to this bug.