Bug 1435120 - Gramps in Epel 7 testing can't be installed because it misses two dependencies
Summary: Gramps in Epel 7 testing can't be installed because it misses two dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gramps
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1662501
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 08:27 UTC by mail
Modified: 2019-01-26 00:48 UTC (History)
7 users (show)

Fixed In Version: gramps-5.0.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-26 00:48:59 UTC


Attachments (Terms of Use)

Description mail 2017-03-23 08:27:11 UTC
Description of problem:
There are two missing dependencies that gramps needs to be installed: 
gnome-python2-gnomeprint
pyicu


Version-Release number of selected component (if applicable):
3.4.8-1.el7

How reproducible:
Always

Steps to Reproduce:
1.Enable epel-testing repo in el 7 (my system is Centos 7) 
2.yum install gramps


Actual results:
gramps cant be installed because of missing dependencies that are not provided by epel-testing either. 

Expected results:
The missing dependencies should be packaged with epel-testing or preferably epel

Additional info:
In addition to the missing dependencies epel-testing causes another conflict with the system packages when enabled in Centos 7: 
Error: Package: gramps-3.4.8-1.el7.noarch (epel-testing)
           Requires: gnome-python2-gnomeprint
Error: Package: gramps-3.4.8-1.el7.noarch (epel-testing)
           Requires: pyicu
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7.centos.6.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.6.x86_64
ipa-client-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.6.noarch
ipa-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.6.noarch

Comment 1 Leslie 2017-12-07 17:47:04 UTC
"There are two missing dependencies that gramps needs to be installed: 
gnome-python2-gnomeprint
pyicu"

Confirmed/replicated under CentOS 3.10.0-693.5.2.el7.x86_64 as of December 7, 2017.

Comment 2 bill 2018-01-14 00:06:03 UTC
Confirmed here as well. This is show stopper for us as a historical society. We need to upgrade from EL6 where we have data stored on gramps.

Comment 3 Leslie 2018-01-19 17:53:00 UTC
(In reply to bill from comment #2)
> Confirmed here as well. This is show stopper for us as a historical society.
> We need to upgrade from EL6 where we have data stored on gramps.

I did come up with a workaround, based on the fact that, while yum will not let you install software with unresolved dependencies, rpm will.  The command

    yum install gnome-python2-gconf gnome-python2-gnome gnome-python2-gnomevfs gnome-python2-gtkspell graphviz pyexiv2 python-enchant

installs all the gramps dependencies available, and the command

    rpm -Uvh --nodeps $(repoquery --enablerepo=epel-testing --location gramps)

will then install gramps itself.  Of course, you won't have the functions provided by the missing dependencies, but the main gramps program ran for me without them.

Comment 4 bill 2018-01-20 03:22:30 UTC
Thanks Leslie.
That will do us nicely for the time being.

Comment 5 bill 2018-01-23 23:40:14 UTC
(In reply to bill from comment #4)
> Thanks Leslie.
> That will do us nicely for the time being.

There is another dependency that should be included in the yum install:
rcs

I'm not sure what part it plays.

Comment 6 Kelsie Flynn 2018-05-04 15:20:35 UTC
I'm working on getting the latest gramps working with el7, 
without forcing it.


So far here is what I have discovered that may need to be done to get it done properly or close to proper.
This is not a easy fix as it depends on a few things.
FYI,  contributing this now incase anyone wants to take this an run with it.
Just needs fixed.



These are the high level stages for now, more testing needed.



I started with gramps 3.4.8 from fedora-epel testing repo.

gramps-3.4.8-1.el7.src.rpm


run a yum-builddeps on it:



For  the requires in the gramps.spec
Change:
Requires:       gnome-python2-gnomeprint 

to 

Requires:       gnome-python2-extras

*Make sure you have libicu-devel installed




*If you want the gramps GPS module portion to potentially work, then:

Rebuild the dep "osm-gps-map"

osm-gps-map-1.0.1-10.el7.src.rpm
i
n the spec under the gobject package:
change
#Obsoletes:      python-osmgpsmap
to
Provides:      python-osmgpsmap


For pyicu:

pyicu-1.5-22.fc27.src.rpm


To get it working :
I used the older pyicu from fc27, since fc28 jumps to 2.0.X and needs a newer libicu, I think.
*TBD later, if i /we can bump it up to 1.9.X at least.
	
Then, run a yum-buildep on it:
You will notice errors:
Error: No Package found for python3-devel
Error: No Package found for python3-setuptools


No problem, copy the old spec to a new one.
Change the a couple BuildRequires: references for python3-* to python34-*

Regerate a new SRPM, then run yum-buildeps again to make sure you have the new deps right for
	python34



When done you should have:
pyicu-1.5-22.el7.x86_64.rpm  pyicu-debuginfo-1.5-22.el7.x86_64.rpm  python3-pyicu-1.5-22.el7.x86_64.rpm

Install as needed.
*Follow up testing needs done on  any  potentially affect python3 vars, that may need changing due to package redefinitions.




Good Luck.

I'll do this on a a clean el7 based install and see I can clean this up and cover anything I missed later.
Dont wait on me, fix it if you can and contribute the fix.
Let others know, if it works for you, then after some testing and approval maybe we can get the changes needed in our repos.
	
Personal Note:
Please dont come along and insult me with all the typical lines and excuses of why this wont/cant/never could work , cause I will not respond to such. Since it does work, can and will, if we choose.

"WONT FIX" is not in my vocabulary at this time.

Comment 7 Kelsie Flynn 2018-05-04 15:51:22 UTC
Also as bill noted above:

Need to add:

rcs

to the requires of the appropriate spec, too.

Comment 8 Kelsie Flynn 2018-05-04 17:40:47 UTC
Okay here's what I came up with.

*Use moc or at least a private limited account for rpm builds

1st.
Make sure you have epel repo setup and updated to latest.

PYICU EL7 START.

Your gonna need pyicu, we have a few options here.
One is using pip to install it from within a rpm script.

*You could also just grab the binary from another repo and force it in, but whats the point of that.
We can prove we can link binaries manually all day long  in a nasty way but not fix it a better way, so skip it, except for testing.

Another better way would be to use another reasonable older version and rebuild as needed,
which is what I did. I found the latest one before the latest major upgrade.
Eg. See here:
https://rpms.remirepo.net/rpmphp/zoom.php?rpm=pyicu

So grab:

pyicu-1.5-22.fc27.src.rpm

from a repo of your choice.
Install the src.rpm.
got to specs dir and make a copy/backup of pyicu.spec

increment the Release and note its a special build with your intials or something, eg.
Eg.
Release:        23%{?dist}
to
Release:        24.alt.testing%{?dist}

Change :

BuildRequires:  python3-devel
BuildRequires:  python3-setuptools

to

BuildRequires:  python34-devel
BuildRequires:  python34-setuptools


Change: 
%package -n python3-pyicu
to
%package -n python34-pyicu


Change:
%description -n python3-pyicu
to 
%description -n python34-pyicu

Change:
%files -n python3-pyicu
to
%files -n python34-pyicu

####
*Leave the sitearch references and other vars alone for now.
*TBD later by someone the knows better, if needs changed. 
*To me it appears to work without changing and 
*rpm --showrc only shows references for python2_sitearch and python_sitearch
####


Now build just the src.rpm so we can run a new builddeps against it.
$rpmbuild -bs pyicu.spec

go to it and run the deps cmd
#yum-builddep -y ./pyicu-1.5*

go back to specs as moc or limited user/whatever and build it full.
$rpmbuild -bs pyicu.spec

You should get a few rpms shortly, install those  as root or sudo if you have it setup, skip the debuginfo one, unless you want to help debug later.


-rw-rw-r--. 1 pyicu pyicu 177444 May  4 13:10 pyicu-1.5-24.alt.testing.el7.x86_64.rpm


-rw-rw-r--. 1 pyicu pyicu 173912 May  4 13:10 python34-pyicu-1.5-24.alt.testing.el7.x86_64.rpm


#yum install  -y pyicu-1.5-24.alt.testing.el7.x86_64.rpm python34-pyicu-1.5-24.alt.testing.el7.x86_64.rpm


PYICU EL7 DONE.


Now onto GRAMPS


#yumdownloader --source gramps --enablerepo=epel-testing
	
#yum-builddep  -y gramps*



$rpm -ivh gramps*.src.rpm

go to spec, make backup copy.


increment the Release in spec.



Change requires for:
Requires:       gnome-python2-gnomeprint

to 

Requires:       gnome-python2-extras


rebuild the new rpm and i, go to it and nstall afterwards with:

#yum install -y ./gramps*


*use Yum not rpm, so you can pull in the associated deps easily.
as this shows:

Dependencies Resolved

===============================================================================================================================================================================
 Package                                        Arch                           Version                                Repository                                          Size
===============================================================================================================================================================================
Installing:
 gramps                                         noarch                         3.4.8-1.el7                            /gramps-3.4.8-1.el7.noarch                          39 M
Installing for dependencies:
 boost-python                                   x86_64                         1.53.0-27.el7                          sl                                                 128 k
 gnome-python2-extras                           x86_64                         2.25.3-46.el7                          epel                                                33 k
 gnome-python2-gtkspell                         x86_64                         2.25.3-46.el7                          epel                                                25 k
 graphviz                                       x86_64                         2.30.1-19.el7                          sl                                                 1.3 M
 gtkspell                                       x86_64                         2.0.16-8.el7                           sl                                                  40 k
 pyexiv2                                        x86_64                         0.3.2-22.el7                           epel                                               259 k
 python-enchant                                 noarch                         1.6.5-14.el7                           epel                                                97 k
 rcs                                            x86_64                         5.9.0-5.el7                            sl                                                 229 k




You could be done here, if you could live with the osm-gps-map module error not loaded. But like me your probably dont like seeing that, so lets address that.
	*But if you are okay without the Geography functionality, go ahead and use it and let us know how it works without it, if any problems occur.
	
To add the functionality:
Lets rebuild  osm-gps-map from fedora and silence that error or stern warning.

Its in the epel repo and just needs the Provides for what the program is looking for, which was commented out long ago. So lets revert and provide it.

$ yumdownloader --source osm-gps-map

#yum-builddep -y ./osm-gps*
	
This will pullin the xorg/x11 deps and all needed.

As limited user/moc/whatever go and install the rpm:

$rpm -ivh osm-gps-map-1.0.1-10.el7.src.rpm
edit the spec
update Release/increment

Change:
Obsoletes:      python-osmgpsmap
to
Provides:       python-osmgpsmap


Build it!
Install it with yum or rpm directly.
#rpm -ivh osm-gps-map-1.0.1-11.el7.x86_64.rpm osm-gps-map-gobject-1.0.1-11.el7.x86_64.rpm


Give gramps another try, it should start up. I've briefly tested it by imported a old gramps file from years ago, no problems so far making reports and such.
YMMV, let us know.



Now what?

In my humble opinion, okay maybe not so humble, but eitherway, these changes should go into epel-testing along with a new rpm from pyicu. 
* Then it would be nice if a python guru would get on this after some testing and see what needs to be done and get us on up  to current pyicu up to 2.0.X.
*Could be easy or not, i dunno.

Comment 9 Kelsie Flynn 2018-05-04 17:48:16 UTC
I noticed a error in my instructions already. 

go back to specs as moc or limited user/whatever and build it full.
$rpmbuild -bs pyicu.spec


should be
go back to specs as moc or limited user/whatever and build it full.
$rpmbuild -ba pyicu.spec


a or all not s for source.

Maybe more, post them if you see em.

Comment 10 Kelsie Flynn 2018-05-04 17:51:14 UTC
Some nice person should come along now and make a patch for us and get this into epel or smack me down and call me an idiot, well see how it goes.

Comment 11 Kelsie Flynn 2018-05-12 16:24:56 UTC
On rebuild/review of the related RPMS for my projects, it appears the rebuild of osm-gps-map and its gobject, does nothing to resolve the osm-gps module notice on startup of gramps.

I was sure before after a build this resolved it, but can't reproduce it now.


So the last step for "python-osmgpsmap" should be skipped unless you just want to muck around and see if the GPS module is working.
I will be glad to rebuild it/ rework it if anyone has any tips.

Comment 12 Kelsie Flynn 2018-05-12 16:29:01 UTC
These gramps.spec changes could and perhaps should go into epel-testing along with a new rpm from pyicu/python34-pyicu. Just skip the osm-gps-map rebuild portion at end completely for now. Later perhaps we can fix the osm-gps-map functionality.

Comment 13 bill 2018-05-13 00:48:17 UTC
(In reply to Leslie from comment #3)
> I did come up with a workaround, based on the fact that, while yum will not
> let you install software with unresolved dependencies, rpm will.  The command
> 
>     yum install gnome-python2-gconf gnome-python2-gnome
> gnome-python2-gnomevfs gnome-python2-gtkspell graphviz pyexiv2 python-enchant
> 

pyexiv2 in EPEL will need to be updated for el7.5 to resolve another dependency issue.

Comment 14 Kelsie Flynn 2018-05-13 03:54:08 UTC
(In reply to bill from comment #13)
> (In reply to Leslie from comment #3)
> > I did come up with a workaround, based on the fact that, while yum will not
> > let you install software with unresolved dependencies, rpm will.  The command
> > 
> >     yum install gnome-python2-gconf gnome-python2-gnome
> > gnome-python2-gnomevfs gnome-python2-gtkspell graphviz pyexiv2 python-enchant
> > 
> 
> pyexiv2 in EPEL will need to be updated for el7.5 to resolve another
> dependency issue.

Yes Bill, thanks for mentioning that.
 I just upgraded to 7.5 and quite a few of my third party programs had to be rebuilt due to the exiv2 so lib symlink "libexiv2.so.26", many programs will complain as they are built against libexiv2.so.12. I could have just created a symlink from 26 to a new 12, but I opted to just rebuild all needed. It may not apply direct, but when building deps note qt5.9.2 is new(up from 5.6) and will likely cause some needed rebuilds as well, once you get into it.

Comment 15 Robert Scheck 2018-12-29 01:54:00 UTC
From what I can see, no gramps version did ever successfully land in EPEL 7, thus I am working to get the current gramps-5.0.1-1.el7 instead of the ancient gramps-3.4.8-1.el7 really done. Satisfying the gramps-3.4.8-1.el7 dependency chain seems to be tricky due to meanwhile orphaned/retired packages even in EPEL 7. But as of writing, for gramps-5.0.1-1.el7 there is only python34-bsddb3 missing (python34-pyicu is meanwhile available). And even in case somebody installed gramps-3.4.8-1.el7 by building the missing dependencies manually, the upgrade path from 3.4.8 -> 5.0.1 (inline) worked here like a charm with 6000+ persons, 2000+ families, 9000+ events, 900+ locations, 100+ sources, 800+ citations. While this test scenario indeed does not cover everything, it's at least not a minor dummy test.

Comment 16 Robert Scheck 2018-12-29 01:58:42 UTC
If I'm not completely mistaken, Benjamin (default assignee/package owner) never commented here, thus I'm taking the freedom to reassign this to myself in the hope to get the last remaining two tasks (build/maintain python34-bsddb3, build latest gramps) hopefully solved really soon.

Comment 17 Robert Scheck 2018-12-29 02:19:53 UTC
If somebody is interested to test what I would like to get into EPEL 7:

 - https://koji.fedoraproject.org/koji/buildinfo?buildID=1176015 (get python34-pyicu-1.5-25.el7.x86_64.rpm)
 - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713993 (get python34-bsddb3-6.2.6-3.el7.x86_64.rpm)
 - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713990 (get gramps-5.0.1-1.el7.noarch.rpm)
 - yum localinstall python34-pyicu-1.5-25.el7.x86_64.rpm python34-bsddb3-6.2.6-3.el7.x86_64.rpm gramps-5.0.1-1.el7.noarch.rpm

Testing feedback is appreciated even it seems to work here as expected.

Comment 18 bill 2018-12-29 06:23:48 UTC
I have tested, converting my EPEL 6 gramps-3.4.8-1 data and it all looks good (2000 families, 5000 people).
When I installed all available add-ons, I got an error  running Graph View (https://gramps-project.org/wiki/index.php?title=Graph_View) which indicated there were missing python dependencies.
It doesn't indicate which python items are missing. Where shall I look for more info. on this issue?
Anyway, thank you for getting everything else working.
Cheers
Bill

Comment 19 Robert Scheck 2018-12-29 12:54:27 UTC
(In reply to bill from comment #18)
> It doesn't indicate which python items are missing. Where shall I look for more info. on this issue?

The error message mentioned GooCanvas2 here. Thus I did "yum install goocanvas2"; seems to work after a gramps restart.

Comment 20 bill 2018-12-29 23:27:07 UTC
(In reply to Robert Scheck from comment #19)
> (In reply to bill from comment #18)
> > It doesn't indicate which python items are missing. Where shall I look for more info. on this issue?
> 
> The error message mentioned GooCanvas2 here. Thus I did "yum install
> goocanvas2"; seems to work after a gramps restart.

My bad!
Too much alcohol mixed with 42C heat.

Comment 21 bill 2019-01-01 00:52:16 UTC
(In reply to Robert Scheck from comment #17)
> If somebody is interested to test what I would like to get into EPEL 7:
> 
>  - https://koji.fedoraproject.org/koji/buildinfo?buildID=1176015 (get
> python34-pyicu-1.5-25.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713993 (get
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713990 (get
> gramps-5.0.1-1.el7.noarch.rpm)
>  - yum localinstall python34-pyicu-1.5-25.el7.x86_64.rpm
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm gramps-5.0.1-1.el7.noarch.rpm
> 
> Testing feedback is appreciated even it seems to work here as expected.

I have now tested using a Samba share of the data to a Windows 10 Gramps 5.0.1 and that required a further BSDDB update from (5, 3, 21) to (6, 0, 30).
So do we need a newer version of bsddb for the Linux setup?

Comment 22 Robert Scheck 2019-01-01 00:57:43 UTC
According to https://pypi.org/project/bsddb3/, 6.2.6 is the latest version. Aside of that, SQLite is part of RHEL 7, thus anyway frozen (in case this reflects the SQLite version itself; SQLite will only be updated/rebased with RHEL 8). Using the same gramps binary data store for Windows and Linux is technically a bad idea (especially when mixing Windows gramps builds and a long-term supported Linux distribution such as CentOS) and is thus unsupported from my side (because the past with CentOS/EPEL 6 would have had similar issues, too). This is something, which is not adressable/solvable with long-term supported Linux distributions, ever.

Comment 23 Robert Scheck 2019-01-01 01:06:05 UTC
Sorry, I meant Berkeley DB rather SQLite. But the rest applies. And it is the BDB version (libdb-5.3.21-24.el7.x86_64, which is a package in the base repository, thus driven by RHEL 7, likely no rebase before RHEL 8).

Comment 24 bill 2019-01-01 03:10:13 UTC
(In reply to Robert Scheck from comment #23)
> Sorry, I meant Berkeley DB rather SQLite. But the rest applies. And it is
> the BDB version (libdb-5.3.21-24.el7.x86_64, which is a package in the base
> repository, thus driven by RHEL 7, likely no rebase before RHEL 8).

Thanks for your comments. I understand and completely agree.
I will rebase the Windows 10 machine to Scientific Linux 7 with Mate (my preferred flavour) and see if the user notices the difference <grin>
Happy New Year
Bill

Comment 25 Fedora Update System 2019-01-09 01:44:03 UTC
gramps-5.0.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-7b029e9ee8

Comment 26 Kelsie Flynn 2019-01-09 10:10:54 UTC
(In reply to Robert Scheck from comment #17)
> If somebody is interested to test what I would like to get into EPEL 7:
> 
>  - https://koji.fedoraproject.org/koji/buildinfo?buildID=1176015 (get
> python34-pyicu-1.5-25.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713993 (get
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713990 (get
> gramps-5.0.1-1.el7.noarch.rpm)
>  - yum localinstall python34-pyicu-1.5-25.el7.x86_64.rpm
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm gramps-5.0.1-1.el7.noarch.rpm
> 
> Testing feedback is appreciated even it seems to work here as expected.


Thanks for the work Robert. I dont use gramps as much as you guys I'm sure so I'm not a good tester I dont think, but....
I did try to do a in place upgrade of my old version and here's what I got. Similar to what Bill said about the db needs. 
I'll even remove mine completely and the old deps I made and see if that helps and repost results if it does.




 Output from upgrade :

yum upgrade https://kojipkgs.fedoraproject.org//packages/gramps/5.0.1/1.el7/noarch/gramps-5.0.1-1.el7.noarch.rpm
Loaded plugins: fastestmirror, langpacks
gramps-5.0.1-1.el7.noarch.rpm                                                                                 | 9.4 MB  00:00:07     
Examining /var/tmp/yum-root-q1a3cf/gramps-5.0.1-1.el7.noarch.rpm: gramps-5.0.1-1.el7.noarch
Marking /var/tmp/yum-root-q1a3cf/gramps-5.0.1-1.el7.noarch.rpm as an update to gramps-3.4.8-3.kgf.el7.noarch
Resolving Dependencies
--> Running transaction check
---> Package gramps.noarch 0:3.4.8-3.kgf.el7 will be updated
---> Package gramps.noarch 0:5.0.1-1.el7 will be an update
--> Processing Dependency: osm-gps-map-gobject for package: gramps-5.0.1-1.el7.noarch
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                                                                          |  19 kB  00:00:00     
 * elrepo: reflector.westga.edu
 * elrepo-kernel: reflector.westga.edu
 * epel: mirror.steadfastnet.com
 * repos: ftp.scientificlinux.org
 * rpmfusion-free-updates: mirror.math.princeton.edu
 * sl: ftp.scientificlinux.org
 * sl-extras: ftp.scientificlinux.org
 * sl-fastbugs: ftp.scientificlinux.org
 * sl-security: ftp.scientificlinux.org
elrepo                                                                                                        | 2.9 kB  00:00:00     
elrepo-kernel                                                                                                 | 2.9 kB  00:00:00     
google-chrome                                                                                                 | 1.3 kB  00:00:00     
repos                                                                                                         | 2.6 kB  00:00:00     
rpmfusion-free-updates                                                                                        | 3.0 kB  00:00:00     
sf-automyth_repo                                                                                              | 2.9 kB  00:00:00     
sl                                                                                                            | 3.8 kB  00:00:00     
sl-extras                                                                                                     | 3.1 kB  00:00:00     
sl-fastbugs                                                                                                   | 2.9 kB  00:00:00     
sl-security                                                                                                   | 2.9 kB  00:00:00     
softwarecollections                                                                                           | 3.0 kB  00:00:00     
--> Processing Dependency: python34-bsddb3 for package: gramps-5.0.1-1.el7.noarch
--> Processing Dependency: python34-gobject for package: gramps-5.0.1-1.el7.noarch
--> Processing Dependency: python34-pyicu for package: gramps-5.0.1-1.el7.noarch
--> Running transaction check
---> Package gramps.noarch 0:5.0.1-1.el7 will be an update
--> Processing Dependency: python34-bsddb3 for package: gramps-5.0.1-1.el7.noarch
--> Processing Dependency: python34-pyicu for package: gramps-5.0.1-1.el7.noarch
---> Package osm-gps-map-gobject.x86_64 0:1.1.0-2.el7 will be installed
---> Package python34-gobject.x86_64 0:3.22.0-4.el7 will be installed
--> Processing Dependency: python34-gobject-base(x86-64) = 3.22.0-4.el7 for package: python34-gobject-3.22.0-4.el7.x86_64
--> Processing Dependency: python34-cairo(x86-64) for package: python34-gobject-3.22.0-4.el7.x86_64
--> Running transaction check
---> Package gramps.noarch 0:5.0.1-1.el7 will be an update
--> Processing Dependency: python34-bsddb3 for package: gramps-5.0.1-1.el7.noarch
--> Processing Dependency: python34-pyicu for package: gramps-5.0.1-1.el7.noarch
---> Package python34-cairo.x86_64 0:1.10.0-24.el7 will be installed
---> Package python34-gobject-base.x86_64 0:3.22.0-4.el7 will be installed
--> Finished Dependency Resolution
Error: Package: gramps-5.0.1-1.el7.noarch (/gramps-5.0.1-1.el7.noarch)
           Requires: python34-pyicu
Error: Package: gramps-5.0.1-1.el7.noarch (/gramps-5.0.1-1.el7.noarch)
           Requires: python34-bsddb3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 27 Robert Scheck 2019-01-09 10:16:55 UTC
(In reply to Kelsie Flynn from comment #26)
> Thanks for the work Robert. I dont use gramps as much as you guys I'm sure
> so I'm not a good tester I dont think, but....
> I did try to do a in place upgrade of my old version and here's what I got.
> Similar to what Bill said about the db needs. 
> I'll even remove mine completely and the old deps I made and see if that
> helps and repost results if it does.

I am sorry, but if you ignore most of the steps from comment #17, you end exactly up with what you posted in comment #26 ;-) Alternatively wait a few days until gramps has been pushed to epel-testing.

Comment 28 Kelsie Flynn 2019-01-09 10:24:02 UTC
(In reply to Robert Scheck from comment #27)
> (In reply to Kelsie Flynn from comment #26)
> > Thanks for the work Robert. I dont use gramps as much as you guys I'm sure
> > so I'm not a good tester I dont think, but....
> > I did try to do a in place upgrade of my old version and here's what I got.
> > Similar to what Bill said about the db needs. 
> > I'll even remove mine completely and the old deps I made and see if that
> > helps and repost results if it does.
> 
> I am sorry, but if you ignore most of the steps from comment #17, you end
> exactly up with what you posted in comment #26 ;-) Alternatively wait a few
> days until gramps has been pushed to epel-testing.


Yes i did at first, not intentionally it's barely 5:30am ;p


(In reply to Robert Scheck from comment #17)
> If somebody is interested to test what I would like to get into EPEL 7:
> 
>  - https://koji.fedoraproject.org/koji/buildinfo?buildID=1176015 (get
> python34-pyicu-1.5-25.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713993 (get
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm)
>  - https://koji.fedoraproject.org/koji/taskinfo?taskID=31713990 (get
> gramps-5.0.1-1.el7.noarch.rpm)
>  - yum localinstall python34-pyicu-1.5-25.el7.x86_64.rpm
> python34-bsddb3-6.2.6-3.el7.x86_64.rpm gramps-5.0.1-1.el7.noarch.rpm
> 
> Testing feedback is appreciated even it seems to work here as expected.


I didnt put the 2 deps in before duh..Awful early here for me.
Once I removed my old ones and installed all 3, installed perfect. Very nice job Robert, thanks.

yum install https://kojipkgs.fedoraproject.org//packages/gramps/5.0.1/1.el7/noarch/gramps-5.0.1-1.el7.noarch.rpm https://kojipkgs.fedoraproject.org//packages/pyicu/1.5/25.el7/x86_64/python34-pyicu-1.5-25.el7.x86_64.rpm https://kojipkgs.fedoraproject.org//work/tasks/3993/31713993/python34-bsddb3-6.2.6-3.el7.x86_64.rpm
Loaded plugins: fastestmirror, langpacks
gramps-5.0.1-1.el7.noarch.rpm                                                                                 | 9.4 MB  00:00:06     
Examining /var/tmp/yum-root-q1a3cf/gramps-5.0.1-1.el7.noarch.rpm: gramps-5.0.1-1.el7.noarch
Marking /var/tmp/yum-root-q1a3cf/gramps-5.0.1-1.el7.noarch.rpm to be installed
python34-pyicu-1.5-25.el7.x86_64.rpm                                                                          | 170 kB  00:00:00     
Examining /var/tmp/yum-root-q1a3cf/python34-pyicu-1.5-25.el7.x86_64.rpm: python34-pyicu-1.5-25.el7.x86_64
Marking /var/tmp/yum-root-q1a3cf/python34-pyicu-1.5-25.el7.x86_64.rpm to be installed
python34-bsddb3-6.2.6-3.el7.x86_64.rpm                                                                        | 218 kB  00:00:00     
Examining /var/tmp/yum-root-q1a3cf/python34-bsddb3-6.2.6-3.el7.x86_64.rpm: python34-bsddb3-6.2.6-3.el7.x86_64
Marking /var/tmp/yum-root-q1a3cf/python34-bsddb3-6.2.6-3.el7.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package gramps.noarch 0:5.0.1-1.el7 will be installed
--> Processing Dependency: osm-gps-map-gobject for package: gramps-5.0.1-1.el7.noarch
Loading mirror speeds from cached hostfile
 * elrepo: reflector.westga.edu
 * elrepo-kernel: reflector.westga.edu
 * epel: mirror.steadfastnet.com
 * repos: ftp.scientificlinux.org
 * rpmfusion-free-updates: mirror.math.princeton.edu
 * sl: ftp.scientificlinux.org
 * sl-extras: ftp.scientificlinux.org
 * sl-fastbugs: ftp.scientificlinux.org
 * sl-security: ftp.scientificlinux.org
--> Processing Dependency: python34-gobject for package: gramps-5.0.1-1.el7.noarch
---> Package python34-bsddb3.x86_64 0:6.2.6-3.el7 will be installed
---> Package python34-pyicu.x86_64 0:1.5-25.el7 will be installed
--> Running transaction check
---> Package osm-gps-map-gobject.x86_64 0:1.1.0-2.el7 will be installed
---> Package python34-gobject.x86_64 0:3.22.0-4.el7 will be installed
--> Processing Dependency: python34-gobject-base(x86-64) = 3.22.0-4.el7 for package: python34-gobject-3.22.0-4.el7.x86_64
--> Processing Dependency: python34-cairo(x86-64) for package: python34-gobject-3.22.0-4.el7.x86_64
--> Running transaction check
---> Package python34-cairo.x86_64 0:1.10.0-24.el7 will be installed
---> Package python34-gobject-base.x86_64 0:3.22.0-4.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================
 Package                          Arch              Version                     Repository                                      Size
=====================================================================================================================================
Installing:
 gramps                           noarch            5.0.1-1.el7                 /gramps-5.0.1-1.el7.noarch                      49 M
 python34-bsddb3                  x86_64            6.2.6-3.el7                 /python34-bsddb3-6.2.6-3.el7.x86_64            1.1 M
 python34-pyicu                   x86_64            1.5-25.el7                  /python34-pyicu-1.5-25.el7.x86_64              640 k
Installing for dependencies:
 osm-gps-map-gobject              x86_64            1.1.0-2.el7                 epel                                            10 k
 python34-cairo                   x86_64            1.10.0-24.el7               epel                                           510 k
 python34-gobject                 x86_64            3.22.0-4.el7                epel                                           9.3 k
 python34-gobject-base            x86_64            3.22.0-4.el7                epel                                           289 k

Transaction Summary
=====================================================================================================================================
Install  3 Packages (+4 Dependent packages)

Total size: 51 M
Total download size: 818 k
Installed size: 53 M
Is this ok [y/d/N]: y
Downloading packages:
(1/4): osm-gps-map-gobject-1.1.0-2.el7.x86_64.rpm                                                             |  10 kB  00:00:00     
(2/4): python34-gobject-3.22.0-4.el7.x86_64.rpm                                                               | 9.3 kB  00:00:00     
(3/4): python34-gobject-base-3.22.0-4.el7.x86_64.rpm                                                          | 289 kB  00:00:01     
(4/4): python34-cairo-1.10.0-24.el7.x86_64.rpm                                                                | 510 kB  00:00:01     
-------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                551 kB/s | 818 kB  00:00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : python34-gobject-base-3.22.0-4.el7.x86_64                                                                                                                             1/7 
  Installing : python34-cairo-1.10.0-24.el7.x86_64                                                                                                                                   2/7 
  Installing : python34-gobject-3.22.0-4.el7.x86_64                                                                                                                                  3/7 
  Installing : python34-bsddb3-6.2.6-3.el7.x86_64                                                                                                                                    4/7 
  Installing : python34-pyicu-1.5-25.el7.x86_64                                                                                                                                      5/7 
  Installing : osm-gps-map-gobject-1.1.0-2.el7.x86_64                                                                                                                                6/7 
  Installing : gramps-5.0.1-1.el7.noarch                                                                                                                                             7/7 
  Verifying  : osm-gps-map-gobject-1.1.0-2.el7.x86_64                                                                                                                                1/7 
  Verifying  : python34-pyicu-1.5-25.el7.x86_64                                                                                                                                      2/7 
  Verifying  : gramps-5.0.1-1.el7.noarch                                                                                                                                             3/7 
  Verifying  : python34-bsddb3-6.2.6-3.el7.x86_64                                                                                                                                    4/7 
  Verifying  : python34-cairo-1.10.0-24.el7.x86_64                                                                                                                                   5/7 
  Verifying  : python34-gobject-base-3.22.0-4.el7.x86_64                                                                                                                             6/7 
  Verifying  : python34-gobject-3.22.0-4.el7.x86_64                                                                                                                                  7/7 

Installed:
  gramps.noarch 0:5.0.1-1.el7                             python34-bsddb3.x86_64 0:6.2.6-3.el7                             python34-pyicu.x86_64 0:1.5-25.el7                            

Dependency Installed:
  osm-gps-map-gobject.x86_64 0:1.1.0-2.el7      python34-cairo.x86_64 0:1.10.0-24.el7      python34-gobject.x86_64 0:3.22.0-4.el7      python34-gobject-base.x86_64 0:3.22.0-4.el7     

Complete!

Comment 29 Kelsie Flynn 2019-01-09 10:27:11 UTC
Furthermore, it updated my old family tree just fine it appears to me as well. But what do i know, as said before I really dont use it enough to be a good tester.

Comment 30 Kelsie Flynn 2019-01-09 10:45:26 UTC
(In reply to bill from comment #24)
> (In reply to Robert Scheck from comment #23)
> > Sorry, I meant Berkeley DB rather SQLite. But the rest applies. And it is
> > the BDB version (libdb-5.3.21-24.el7.x86_64, which is a package in the base
> > repository, thus driven by RHEL 7, likely no rebase before RHEL 8).
> 
> Thanks for your comments. I understand and completely agree.
> I will rebase the Windows 10 machine to Scientific Linux 7 with Mate (my
> preferred flavour) and see if the user notices the difference <grin>
> Happy New Year
> Bill



Now i've read a little more  :)


Bill probably already knows this answer but Im not clear still...

Correct me where I'm wrong please.
So your putting this up to go into "testing"

I completely understand about the base package in 7 that wont be changed till 8. 
I'm NOT the authority on anything outside my house but,  I suspect they may reject any package into EPEL that will conflict, unless its in a SCL type package kit perhaps.
I dont know, but look forward to seeing the outcome here.

Comment 31 Robert Scheck 2019-01-09 11:00:40 UTC
Yes, gramps (and the "new" dependencies) will be in EPEL 7 testing for about two weeks from now.

It is very unlikely that there will be a major libdb rebase in RHEL 7. SCL is not an option as EPEL 7 only allows the usage of a very few packages from SCL (e.g. new compilers).

The intention with gramps in EPEL 7 is to not create any conflicts, but to make users aware to accept that libdb on RHEL 7 is just older than on other platforms such as Windows.

Comment 32 Kelsie Flynn 2019-01-09 11:10:15 UTC
Thanks for the clarification. 

Just before this. 
I reviewed the contents of both said packages a little more to help me understand.
As I can see how it would be a conflict if it tries to replace a specific file,  but your's looks fine from what I can tell.

If i finally understand more correctly now,
Your not replacing a libdb package at all,  but you've built a python subpackage against a higher libdb3 version than is in EL7 and thus will not be until 8.
So no real conflict just some notes of warning about such until we sync up with 8?

Comment 33 Robert Scheck 2019-01-09 11:19:10 UTC
Gramps requires Python 3, but only Python 2.x is in RHEL 7. Thus some EPEL packagers made python34 packages for EPEL 7. All I did was to ensure there are python34-{bsddb3,pyicu} packages, given gramps requires them. These python packages itself link against libdb and libicu libraries in RHEL 7 (I am not providing newer libdb or libicu). For the switch to RHEL 8, I do not expect any differences compared to what we had from RHEL 6 to 7.

Comment 34 Kelsie Flynn 2019-01-09 11:32:55 UTC
(In reply to Robert Scheck from comment #33)
> Gramps requires Python 3, but only Python 2.x is in RHEL 7. Thus some EPEL
> packagers made python34 packages for EPEL 7. All I did was to ensure there
> are python34-{bsddb3,pyicu} packages, given gramps requires them. These
> python packages itself link against libdb and libicu libraries in RHEL 7 (I
> am not providing newer libdb or libicu). For the switch to RHEL 8, I do not
> expect any differences compared to what we had from RHEL 6 to 7.

Thanks. I was part of those that did made a workaround as well, thus the interest. I appreciate the in depth overview and it may help more than me understand quite a bit in this process. As I'm sure you know anyone can make a package just about but making it all fit right is the fun part that everyone wants to know.

Comment 35 Fedora Update System 2019-01-11 03:28:51 UTC
gramps-5.0.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-7b029e9ee8

Comment 36 Fedora Update System 2019-01-26 00:48:59 UTC
gramps-5.0.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.