Bug 1435166 - perl-CHI-0.60-10.fc27 FTBFS: Failed test 'raw_values = 1 by default'
Summary: perl-CHI-0.60-10.fc27 FTBFS: Failed test 'raw_values = 1 by default'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-CHI
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 10:12 UTC by Petr Pisar
Modified: 2017-06-25 07:19 UTC (History)
4 users (show)

Fixed In Version: perl-CHI-0.60-12.fc26 perl-CHI-0.60-12.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 02:36:01 UTC
Type: Bug


Attachments (Terms of Use)
Proposed fix ported to 0.60 (2.49 KB, patch)
2017-05-03 16:18 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
CPAN 120705 0 None None None 2017-03-23 10:12:06 UTC

Description Petr Pisar 2017-03-23 10:12:06 UTC
perl-CHI-0.60-10.fc27 fails to build in F27 because a test fails:

t/smoke-Driver-CacheCache.t ............. ok
#   Failed test 'raw_values = 1 by default'
#   at /builddir/build/BUILD/CHI-0.60/blib/lib/CHI/t/Driver/FastMmap.pm line 41.
#   (in CHI::t::Driver::FastMmap->test_fm_cache)
#          got: '0'
#     expected: '1'
# Looks like you failed 1 test of 832.
t/smoke-Driver-FastMmap.t ............... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/832 subtests 
	(less 1 skipped subtest: 830 okay)

This is caused by upgrading perl-Cache-FastMmap from 1.44-2.fc26 to 1.45-1.fc27. Cache-FastMmap-1.45 deprecated raw_values option.

Comment 1 Petr Pisar 2017-03-23 14:29:55 UTC
Because perl-Cache-FastMmap-1.45 is built for Fedora ≥ 25, I believe this package will fail to build also in older Fedoras.

Comment 2 Ralf Corsepius 2017-03-23 15:01:54 UTC
(In reply to Petr Pisar from comment #1)
> Because perl-Cache-FastMmap-1.45 is built for Fedora ≥ 25, I believe this
> package will fail to build also in older Fedoras.

I just -1'ed the fc25 update, because it's not yet clear to me if this is just a problem with the testsuite or if perl-Cache-FastMmap-1.45 is breaking perl-CHI itself.

Comment 3 Ralf Corsepius 2017-03-24 05:55:49 UTC
(In reply to Ralf Corsepius from comment #2)
> (In reply to Petr Pisar from comment #1)
> > Because perl-Cache-FastMmap-1.45 is built for Fedora ≥ 25, I believe this
> > package will fail to build also in older Fedoras.
> 
> I just -1'ed the fc25 update, because it's not yet clear to me if this is
> just a problem with the testsuite or if perl-Cache-FastMmap-1.45 is breaking
> perl-CHI itself.
Running rt's testsuite (Which heavily utilizes perl-CHI) doen't raise any new issue. I therefore am leaning towards considering this issue to be a problem with perl-CHI's testsuite and not to be a general problem with perl-CHI.

Comment 4 Jan Pazdziora 2017-03-29 12:08:08 UTC
Is it OK to push https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3e9d57189 to Fedora 26 stable or will it break things for you badly?

Comment 5 Ralf Corsepius 2017-03-29 13:13:56 UTC
(In reply to Jan Pazdziora from comment #4)
> Is it OK to push
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3e9d57189 to Fedora 26
> stable or will it break things for you badly?
It's OK for me. I thought, I already had "neuralized" my "-1". 

Besides this, it currently doesn't matter much, because rt currently was broken
on probably all released Fedoras by the update to perl-DBD-MySQL-4.042
(https://bodhi.fedoraproject.org/updates/FEDORA-2017-197ef86c60)

Comment 6 Petr Pisar 2017-04-26 06:26:29 UTC
perl-CHI is required for building 10 other packages like perl-HTML-Mason, rt, and some Catalyst things. I recommend focusing on fixing it especially as perl-5.26.0 and Perl mass rebuild lean.

Comment 7 Petr Pisar 2017-05-03 16:18:14 UTC
Created attachment 1275936 [details]
Proposed fix ported to 0.60

I sent a fix to upstream. This is a version ported to CHI-0.60.

Comment 8 Jitka Plesnikova 2017-05-29 10:01:01 UTC
Could you please apply the patch? 

If you are busy, I can fix it.

Comment 9 Ralf Corsepius 2017-05-29 11:16:20 UTC
(In reply to Jitka Plesnikova from comment #8)
> Could you please apply the patch? 
No, I am not going to apply this patch, because I can not reproduce this problem this patch is trying to address.

Comment 10 Jitka Plesnikova 2017-06-07 08:02:33 UTC
Rebuild of perl-CHI with Perl 5.26 failed.
https://koji.fedoraproject.org/koji/taskinfo?taskID=19885936

Please fix the bug.

Comment 11 Fedora Update System 2017-06-15 09:18:03 UTC
perl-CHI-0.60-12.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9e99eeb2e8

Comment 12 Fedora Update System 2017-06-15 09:18:13 UTC
perl-CHI-0.60-12.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-df6f339b49

Comment 13 Fedora Update System 2017-06-16 19:52:24 UTC
perl-CHI-0.60-12.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9e99eeb2e8

Comment 14 Fedora Update System 2017-06-16 22:23:47 UTC
perl-CHI-0.60-12.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-df6f339b49

Comment 15 Fedora Update System 2017-06-21 02:36:01 UTC
perl-CHI-0.60-12.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-06-25 07:19:01 UTC
perl-CHI-0.60-12.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.